aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm47xx
diff options
context:
space:
mode:
authorFelix Baumann <felix.bau@gmx.de>2023-05-20 08:37:45 +0200
committerFelix Baumann <felix.bau@gmx.de>2023-05-21 01:08:22 +0200
commitf5cb556d4f70e7aac428857fe782b58ece0cf188 (patch)
tree5cb0a1675cfec759d97837e3e9fdad955879f21c /target/linux/bcm47xx
parent3f297be1ed49351282f26462a7aa6e03036a1ffc (diff)
downloadupstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.tar.gz
upstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.tar.bz2
upstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.zip
treewide: Disable building 32M RAM devices
Following deprecation notice[1] in 21.02, disable targets with 32M of RAM [1] https://openwrt.org/supported_devices/864_warning Signed-off-by: Felix Baumann <felix.bau@gmx.de>
Diffstat (limited to 'target/linux/bcm47xx')
-rw-r--r--target/linux/bcm47xx/image/generic.mk3
-rw-r--r--target/linux/bcm47xx/image/legacy.mk4
-rw-r--r--target/linux/bcm47xx/image/mips74k.mk21
3 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/bcm47xx/image/generic.mk b/target/linux/bcm47xx/image/generic.mk
index 94064cb7d1..5cab0fa932 100644
--- a/target/linux/bcm47xx/image/generic.mk
+++ b/target/linux/bcm47xx/image/generic.mk
@@ -10,6 +10,7 @@ define Device/linksys_wrt300n-v1.1
$(Device/linksys)
DEVICE_ID := EWC2
VERSION := 1.51.2
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt300n-v1.1
@@ -20,6 +21,7 @@ define Device/linksys_wrt310n-v1
$(Device/linksys)
DEVICE_ID := 310N
VERSION := 1.0.10
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt310n-v1
@@ -30,6 +32,7 @@ define Device/linksys_wrt350n-v1
$(Device/linksys)
DEVICE_ID := EWCG
VERSION := 1.04.1
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt350n-v1
diff --git a/target/linux/bcm47xx/image/legacy.mk b/target/linux/bcm47xx/image/legacy.mk
index 4c37a4505c..b21398deca 100644
--- a/target/linux/bcm47xx/image/legacy.mk
+++ b/target/linux/bcm47xx/image/legacy.mk
@@ -63,6 +63,7 @@ define Device/asus_wl-500w
DEVICE_PACKAGES := kmod-b43 kmod-usb-uhci kmod-usb2-pci
$(Device/asus)
PRODUCTID := "WL500W "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_wl-500w
@@ -119,6 +120,7 @@ define Device/huawei_e970
KERNEL_NAME = vmlinux.gz
IMAGES := bin
IMAGE/bin := append-rootfs | trx-without-loader | huawei-bin
+ DEFAULT := n
endef
TARGET_DEVICES += huawei_e970
@@ -220,6 +222,7 @@ define Device/linksys_wrt160n-v1
$(Device/linksys)
DEVICE_ID := N150
VERSION := 1.50.1
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt160n-v1
@@ -231,6 +234,7 @@ define Device/linksys_wrt300n-v1
IMAGES := bin trx
DEVICE_ID := EWCB
VERSION := 1.03.6
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt300n-v1
diff --git a/target/linux/bcm47xx/image/mips74k.mk b/target/linux/bcm47xx/image/mips74k.mk
index 4478374f16..0f7610f3dd 100644
--- a/target/linux/bcm47xx/image/mips74k.mk
+++ b/target/linux/bcm47xx/image/mips74k.mk
@@ -34,6 +34,7 @@ define Device/asus_rt-n10p
DEVICE_PACKAGES := kmod-b43
$(Device/asus)
PRODUCTID := RT-N10P
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n10p
@@ -42,6 +43,7 @@ define Device/asus_rt-n10p-v2
DEVICE_VARIANT := v2
$(Device/asus)
PRODUCTID := RT-N10PV2
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n10p-v2
@@ -51,6 +53,7 @@ define Device/asus_rt-n10u
DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
$(Device/asus)
PRODUCTID := RT-N10U
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n10u
@@ -60,6 +63,7 @@ define Device/asus_rt-n10u-b
DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
$(Device/asus)
PRODUCTID := RT-N10U
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n10u-b
@@ -69,6 +73,7 @@ define Device/asus_rt-n12
DEVICE_PACKAGES := kmod-b43
$(Device/asus)
PRODUCTID := "RT-N12 "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n12
@@ -77,6 +82,7 @@ define Device/asus_rt-n12-b1
DEVICE_VARIANT := B1
$(Device/asus)
PRODUCTID := RT-N12B1
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n12-b1
@@ -85,6 +91,7 @@ define Device/asus_rt-n12-c1
DEVICE_VARIANT := C1
$(Device/asus)
PRODUCTID := RT-N12C1
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n12-c1
@@ -93,6 +100,7 @@ define Device/asus_rt-n12-d1
DEVICE_VARIANT := D1
$(Device/asus)
PRODUCTID := RT-N12D1
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n12-d1
@@ -100,6 +108,7 @@ define Device/asus_rt-n12hp
DEVICE_MODEL := RT-N12HP
$(Device/asus)
PRODUCTID := RT-N12HP
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n12hp
@@ -132,6 +141,7 @@ define Device/asus_rt-n53
DEVICE_PACKAGES := kmod-b43
$(Device/asus)
PRODUCTID := RT-N53
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n53
@@ -169,6 +179,7 @@ define Device/linksys_wrt310n-v2
$(Device/linksys)
DEVICE_ID := 310N
VERSION := 2.0.1
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt310n-v2
@@ -179,6 +190,7 @@ define Device/linksys_wrt320n-v1
$(Device/linksys)
DEVICE_ID := 320N
VERSION := 1.0.5
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt320n-v1
@@ -188,6 +200,7 @@ define Device/linksys_e900-v1
$(Device/linksys)
DEVICE_ID := E900
VERSION := 1.0.4
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_e900-v1
@@ -198,6 +211,7 @@ define Device/linksys_e1000
$(Device/linksys)
DEVICE_ID := E100
VERSION := 1.1.3
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_e1000
@@ -207,6 +221,7 @@ define Device/linksys_e1200-v1
$(Device/linksys)
DEVICE_ID := E120
VERSION := 1.0.3
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_e1200-v1
@@ -216,6 +231,7 @@ define Device/linksys_e1200-v2
$(Device/linksys)
DEVICE_ID := E122
VERSION := 1.0.4
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_e1200-v2
@@ -225,6 +241,7 @@ define Device/linksys_e1500-v1
$(Device/linksys)
DEVICE_ID := E150
VERSION := 1.0.5
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_e1500-v1
@@ -245,6 +262,7 @@ define Device/linksys_e2000-v1
$(Device/linksys)
DEVICE_ID := 32XN
VERSION := 1.0.4
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_e2000-v1
@@ -353,6 +371,7 @@ define Device/netgear_wn3000rp
$(Device/netgear)
NETGEAR_BOARD_ID := U12H163T01_NETGEAR
NETGEAR_REGION := 1
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wn3000rp
@@ -434,6 +453,7 @@ define Device/netgear_wnr2000v2
$(Device/netgear)
NETGEAR_BOARD_ID := U12H114T00_NETGEAR
NETGEAR_REGION := 2
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wnr2000v2
@@ -486,6 +506,7 @@ define Device/netgear_wnr3500-v2
$(Device/netgear)
NETGEAR_BOARD_ID := U12H127T00_NETGEAR
NETGEAR_REGION := 2
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wnr3500-v2