aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm47xx
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-11-07 14:45:14 +0100
committerRafał Miłecki <rafal@milecki.pl>2021-11-08 15:55:26 +0100
commit4cd97e4760899172a1d6339ea5644992775e504e (patch)
treedc16b93039a13a4cd77fb7334ca3edf365e0e0e8 /target/linux/bcm47xx
parent32ba52e2174d0c12fa476c3295daca12a864e547 (diff)
downloadupstream-4cd97e4760899172a1d6339ea5644992775e504e.tar.gz
upstream-4cd97e4760899172a1d6339ea5644992775e504e.tar.bz2
upstream-4cd97e4760899172a1d6339ea5644992775e504e.zip
bcm47xx: relocate LZMA loader
Kernel 5.10 grew bigger than 5.4 so we need to bump BZ_TEXT_START to allow lzma loader hanel its size. At the same time BZ_STACK_START needs to be increased to avoid overwriting the stack. For a reference see: d5cf4a5aa4a3 ("brcm47xx: relocate loader to higher address") 2909a4b78e2b ("brcm47xx: relocate the stack in loader") Cc: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Rafał Miłecki <rafal@milecki.pl> Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/bcm47xx')
-rw-r--r--target/linux/bcm47xx/image/lzma-loader/src/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/bcm47xx/image/lzma-loader/src/Makefile b/target/linux/bcm47xx/image/lzma-loader/src/Makefile
index a08fc05b9f..a3e7ae1c92 100644
--- a/target/linux/bcm47xx/image/lzma-loader/src/Makefile
+++ b/target/linux/bcm47xx/image/lzma-loader/src/Makefile
@@ -18,8 +18,8 @@
#
TEXT_START := 0x80001000
-BZ_TEXT_START := 0x80600000
-BZ_STACK_START := 0x80700000
+BZ_TEXT_START := 0x80700000
+BZ_STACK_START := 0x80800000
OBJCOPY := $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S