aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm47xx/mips74k
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-07 15:42:54 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-14 14:10:51 +0100
commit8fe5ad5d3373cebed4fbc55a7b779721971ce427 (patch)
tree5d9106ede800508dde24c21dda7f90b8b1b8af5b /target/linux/bcm47xx/mips74k
parent8590e70fab64172700c21bc5e658eba17a1eae70 (diff)
downloadupstream-8fe5ad5d3373cebed4fbc55a7b779721971ce427.tar.gz
upstream-8fe5ad5d3373cebed4fbc55a7b779721971ce427.tar.bz2
upstream-8fe5ad5d3373cebed4fbc55a7b779721971ce427.zip
brcm47xx: rename target to bcm47xx
This change makes the names of Broadcom targets consistent by using the common notation based on SoC/CPU ID (which is used internally anyway), bcmXXXX instead of brcmXXXX. This is even used for target TITLE in make menuconfig already, only the short target name used brcm so far. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/bcm47xx/mips74k')
-rw-r--r--target/linux/bcm47xx/mips74k/config-default20
-rw-r--r--target/linux/bcm47xx/mips74k/profiles/100-Broadcom-b43.mk19
-rw-r--r--target/linux/bcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk19
-rw-r--r--target/linux/bcm47xx/mips74k/profiles/102-Broadcom-wl.mk19
-rw-r--r--target/linux/bcm47xx/mips74k/profiles/103-Broadcom-none.mk18
-rw-r--r--target/linux/bcm47xx/mips74k/target.mk9
6 files changed, 104 insertions, 0 deletions
diff --git a/target/linux/bcm47xx/mips74k/config-default b/target/linux/bcm47xx/mips74k/config-default
new file mode 100644
index 0000000000..2c3c40377a
--- /dev/null
+++ b/target/linux/bcm47xx/mips74k/config-default
@@ -0,0 +1,20 @@
+# CONFIG_ADM6996_PHY is not set
+# CONFIG_BCM47XX_SSB is not set
+CONFIG_BGMAC=y
+CONFIG_BGMAC_BCMA=y
+CONFIG_BOUNCE=y
+# CONFIG_CPU_MIPS32_R1 is not set
+# CONFIG_CPU_MIPSR1 is not set
+CONFIG_CPU_MIPS32_R2=y
+CONFIG_CPU_MIPSR2=y
+# CONFIG_FIXED_PHY is not set
+# CONFIG_GPIO_WDT is not set
+CONFIG_HIGHMEM=y
+# CONFIG_SSB is not set
+# CONFIG_SSB_DRIVER_EXTIF is not set
+# CONFIG_SSB_DRIVER_GIGE is not set
+# CONFIG_SSB_DRIVER_MIPS is not set
+# CONFIG_SSB_EMBEDDED is not set
+# CONFIG_SSB_PCICORE_HOSTMODE is not set
+# CONFIG_SSB_SERIAL is not set
+# CONFIG_SSB_SFLASH is not set
diff --git a/target/linux/bcm47xx/mips74k/profiles/100-Broadcom-b43.mk b/target/linux/bcm47xx/mips74k/profiles/100-Broadcom-b43.mk
new file mode 100644
index 0000000000..bd3b010f69
--- /dev/null
+++ b/target/linux/bcm47xx/mips74k/profiles/100-Broadcom-b43.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-b43
+ NAME:=Broadcom SoC, BCM43xx WiFi (b43)
+ PACKAGES:=kmod-b43
+endef
+
+define Profile/Broadcom-mips74k-b43/Description
+ Package set for devices with BCM43xx WiFi including mac80211 and b43
+ driver.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-b43))
+
diff --git a/target/linux/bcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk b/target/linux/bcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk
new file mode 100644
index 0000000000..a138ef93b0
--- /dev/null
+++ b/target/linux/bcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-brcmsmac
+ NAME:=Broadcom SoC, BCM43xx WiFi (brcmsmac)
+ PACKAGES:=kmod-brcmsmac
+endef
+
+define Profile/Broadcom-mips74k-brcmsmac/Description
+ Package set for devices with BCM43xx WiFi including mac80211 and
+ brcmsmac driver.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-brcmsmac))
+
diff --git a/target/linux/bcm47xx/mips74k/profiles/102-Broadcom-wl.mk b/target/linux/bcm47xx/mips74k/profiles/102-Broadcom-wl.mk
new file mode 100644
index 0000000000..66b13bf879
--- /dev/null
+++ b/target/linux/bcm47xx/mips74k/profiles/102-Broadcom-wl.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-wl
+ NAME:=Broadcom SoC, BCM43xx WiFi (proprietary wl)
+ PACKAGES:=-wpad-basic kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-mips74k-wl/Description
+ Package set for devices with BCM43xx WiFi including proprietary (and
+ closed source) driver "wl".
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-wl))
+
diff --git a/target/linux/bcm47xx/mips74k/profiles/103-Broadcom-none.mk b/target/linux/bcm47xx/mips74k/profiles/103-Broadcom-none.mk
new file mode 100644
index 0000000000..cc4668de52
--- /dev/null
+++ b/target/linux/bcm47xx/mips74k/profiles/103-Broadcom-none.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-none
+ NAME:=Broadcom SoC, No WiFi
+ PACKAGES:=-wpad-basic
+endef
+
+define Profile/Broadcom-mips74k-none/Description
+ Package set for devices without a WiFi.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-none))
+
diff --git a/target/linux/bcm47xx/mips74k/target.mk b/target/linux/bcm47xx/mips74k/target.mk
new file mode 100644
index 0000000000..1e2e8436d5
--- /dev/null
+++ b/target/linux/bcm47xx/mips74k/target.mk
@@ -0,0 +1,9 @@
+BOARDNAME:=MIPS 74K
+CPU_TYPE:=74kc
+
+DEFAULT_PACKAGES += wpad-basic
+
+define Target/Description
+ Build firmware for Broadcom BCM47xx and BCM53xx devices with
+ MIPS 74K CPU.
+endef