aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm47xx/image/generic.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-07 21:11:14 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-12 11:08:05 +0200
commitd0cb71a8962719f2e64d43f9bed808633cfc9cd9 (patch)
treec703c5df51d6cf4464d03c625a93f3609c9cc13f /target/linux/bcm47xx/image/generic.mk
parent683bcbdce163375286c8193cc76c130f02e6649f (diff)
downloadupstream-d0cb71a8962719f2e64d43f9bed808633cfc9cd9.tar.gz
upstream-d0cb71a8962719f2e64d43f9bed808633cfc9cd9.tar.bz2
upstream-d0cb71a8962719f2e64d43f9bed808633cfc9cd9.zip
bcm47xx: use vendor_model scheme for device/image names
Most targets have been updated to consistently use the vendor_model scheme for device definitions and thus, image names. Apply this to bcm47xx as well. This does _not_ apply any other specific naming changes. Cc: Rafał Miłecki <rafal@milecki.pl> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/bcm47xx/image/generic.mk')
-rw-r--r--target/linux/bcm47xx/image/generic.mk24
1 files changed, 12 insertions, 12 deletions
diff --git a/target/linux/bcm47xx/image/generic.mk b/target/linux/bcm47xx/image/generic.mk
index e5ae952137..61204bf232 100644
--- a/target/linux/bcm47xx/image/generic.mk
+++ b/target/linux/bcm47xx/image/generic.mk
@@ -3,7 +3,7 @@
#################################################
# BCM4705 with tg3
-define Device/linksys-wrt300n-v1.1
+define Device/linksys_wrt300n-v1.1
DEVICE_MODEL := WRT300N
DEVICE_VARIANT := v1.1
DEVICE_PACKAGES := kmod-tg3 kmod-b43
@@ -11,9 +11,9 @@ define Device/linksys-wrt300n-v1.1
DEVICE_ID := EWC2
VERSION := 1.51.2
endef
-TARGET_DEVICES += linksys-wrt300n-v1.1
+TARGET_DEVICES += linksys_wrt300n-v1.1
-define Device/linksys-wrt310n-v1
+define Device/linksys_wrt310n-v1
DEVICE_MODEL := WRT310N
DEVICE_VARIANT := v1
DEVICE_PACKAGES := kmod-tg3 kmod-b43
@@ -21,9 +21,9 @@ define Device/linksys-wrt310n-v1
DEVICE_ID := 310N
VERSION := 1.0.10
endef
-TARGET_DEVICES += linksys-wrt310n-v1
+TARGET_DEVICES += linksys_wrt310n-v1
-define Device/linksys-wrt350n-v1
+define Device/linksys_wrt350n-v1
DEVICE_MODEL := WRT350N
DEVICE_VARIANT := v1
DEVICE_PACKAGES := kmod-tg3 kmod-b43 $(USB2_PACKAGES)
@@ -31,9 +31,9 @@ define Device/linksys-wrt350n-v1
DEVICE_ID := EWCG
VERSION := 1.04.1
endef
-TARGET_DEVICES += linksys-wrt350n-v1
+TARGET_DEVICES += linksys_wrt350n-v1
-define Device/linksys-wrt610n-v1
+define Device/linksys_wrt610n-v1
DEVICE_MODEL := WRT610N
DEVICE_VARIANT := v1
DEVICE_PACKAGES := kmod-tg3 kmod-b43 $(USB2_PACKAGES)
@@ -41,10 +41,10 @@ define Device/linksys-wrt610n-v1
DEVICE_ID := 610N
VERSION := 1.0.1
endef
-TARGET_DEVICES += linksys-wrt610n-v1
+TARGET_DEVICES += linksys_wrt610n-v1
# BCMA SoC with SSB WiFi
-define Device/linksys-wrt610n-v2
+define Device/linksys_wrt610n-v2
DEVICE_MODEL := WRT610N
DEVICE_VARIANT := v2
DEVICE_PACKAGES := kmod-bgmac kmod-b43 $(USB2_PACKAGES)
@@ -52,9 +52,9 @@ define Device/linksys-wrt610n-v2
DEVICE_ID := 610N
VERSION := 2.0.0
endef
-TARGET_DEVICES += linksys-wrt610n-v2
+TARGET_DEVICES += linksys_wrt610n-v2
-define Device/linksys-e3000-v1
+define Device/linksys_e3000-v1
DEVICE_MODEL := E3000
DEVICE_VARIANT := v1
DEVICE_PACKAGES := kmod-bgmac kmod-b43 $(USB2_PACKAGES)
@@ -62,7 +62,7 @@ define Device/linksys-e3000-v1
DEVICE_ID := 61XN
VERSION := 1.0.3
endef
-TARGET_DEVICES += linksys-e3000-v1
+TARGET_DEVICES += linksys_e3000-v1
# generic has Ethernet drivers as modules so overwrite standard image
define Device/standard