aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx
diff options
context:
space:
mode:
authorJohannes Heimansberg <git@jhe.dedyn.io>2022-12-12 15:39:58 +0100
committerChristian Lamparter <chunkeey@gmail.com>2022-12-15 15:08:08 +0100
commit708ea56fb9e2b4ab77e726085d572bf80a4cc76a (patch)
tree0a81942cad64685187d265c68210e9b20fff6d62 /target/linux/bcm27xx
parent1bef8d62d42d1dfbda04e8280930488b2661f0fa (diff)
downloadupstream-708ea56fb9e2b4ab77e726085d572bf80a4cc76a.tar.gz
upstream-708ea56fb9e2b4ab77e726085d572bf80a4cc76a.tar.bz2
upstream-708ea56fb9e2b4ab77e726085d572bf80a4cc76a.zip
bcm27xx: bcm2711: add kmod-r8169
Some carrier boards [1][2] for the Raspberry Pi CM4 that are specifically designed to be used as routers come with secondary NICs using a Realtek RTL8111 Gigabit Ethernet chip. When using such a board as a router with OpenWrt, it is very helpful when both NICs are working by default. Since the Raspberry Pi 4 and the CM4 have plenty of disk space, it should cause no harm to include the kmod-r8169. [1] https://wiki.dfrobot.com/Compute_Module_4_IoT_Router_Board_Mini_SKU_DFR0767 [2] https://www.waveshare.com/wiki/CM4-DUAL-ETH-MINI Signed-off-by: Johannes Heimansberg <git@jhe.dedyn.io> (r8169 should pull in the necessary dependencies.) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/bcm27xx')
-rw-r--r--target/linux/bcm27xx/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/bcm27xx/image/Makefile b/target/linux/bcm27xx/image/Makefile
index 1334386c57..999361e8cd 100644
--- a/target/linux/bcm27xx/image/Makefile
+++ b/target/linux/bcm27xx/image/Makefile
@@ -163,7 +163,8 @@ define Device/rpi-4
cypress-firmware-43455-sdio \
brcmfmac-nvram-43455-sdio \
kmod-brcmfmac wpad-basic-wolfssl \
- kmod-usb-net-lan78xx
+ kmod-usb-net-lan78xx \
+ kmod-r8169
IMAGE/sysupgrade.img.gz := boot-common | boot-2711 | sdcard-img | gzip | append-metadata
IMAGE/factory.img.gz := boot-common | boot-2711 | sdcard-img | gzip
endef