aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx
diff options
context:
space:
mode:
authorKuan-Yi Li <kyli@abysm.org>2022-10-22 23:09:19 +0800
committerÁlvaro Fernández Rojas <noltari@gmail.com>2022-11-15 20:47:54 +0100
commitefaad5e901508621a47044dd729c4b776633b9b7 (patch)
tree90f22cde8ce6e587ffe1a8b0a0e3dcdb99ae813a /target/linux/bcm27xx
parentce6f86e1344ccf79b8f8bcd0923f0865b9eb8db4 (diff)
downloadupstream-efaad5e901508621a47044dd729c4b776633b9b7.tar.gz
upstream-efaad5e901508621a47044dd729c4b776633b9b7.tar.bz2
upstream-efaad5e901508621a47044dd729c4b776633b9b7.zip
cypress-nvram: use symlink to provide NVRAM for some RPis
This is to align the implementation with upstream `linux-firmware`. Some Raspberry Pi boards do not have dedicated NVRAM in `linux-firmware` source repository, their NVRAM is provided through a symbolic link to NVRAM of another board with an identical wireless design. Signed-off-by: Kuan-Yi Li <kyli@abysm.org>
Diffstat (limited to 'target/linux/bcm27xx')
-rw-r--r--target/linux/bcm27xx/image/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/target/linux/bcm27xx/image/Makefile b/target/linux/bcm27xx/image/Makefile
index 4cd1052941..650d673025 100644
--- a/target/linux/bcm27xx/image/Makefile
+++ b/target/linux/bcm27xx/image/Makefile
@@ -87,10 +87,10 @@ define Device/rpi-2
DEVICE_MODEL := 2B/2B 1.2
DEVICE_VARIANT := (32bit)
DEVICE_ALT0_VENDOR := Raspberry Pi
- DEVICE_ALT0_MODEL := 3B/3B+/3CM
+ DEVICE_ALT0_MODEL := 3B/3B+/CM3
DEVICE_ALT0_VARIANT := (32bit)
DEVICE_ALT1_VENDOR := Raspberry Pi
- DEVICE_ALT1_MODEL := 4B/400/4CM
+ DEVICE_ALT1_MODEL := 4B/400/CM4
DEVICE_ALT1_VARIANT := (32bit)
DEVICE_DTS := \
bcm2709-rpi-2-b bcm2710-rpi-2-b \
@@ -109,7 +109,9 @@ define Device/rpi-2
cypress-firmware-43430-sdio \
cypress-nvram-43430-sdio-rpi-3b \
cypress-firmware-43455-sdio \
- cypress-nvram-43455-sdio-rpi-3b-plus cypress-nvram-43455-sdio-rpi-4b \
+ cypress-nvram-43455-sdio-rpi-3b-plus \
+ cypress-nvram-43455-sdio-rpi-4b \
+ cypress-nvram-43455-sdio-rpi-cm4 \
kmod-brcmfmac wpad-basic-wolfssl
IMAGE/sysupgrade.img.gz := boot-common | boot-2708 | boot-2711 | sdcard-img | gzip | append-metadata
IMAGE/factory.img.gz := boot-common | boot-2708 | boot-2711 | sdcard-img | gzip
@@ -119,7 +121,7 @@ ifeq ($(SUBTARGET),bcm2709)
endif
define Device/rpi-3
- DEVICE_MODEL := 3B/3B+/3CM
+ DEVICE_MODEL := 3B/3B+/CM3
DEVICE_VARIANT := (64bit)
DEVICE_ALT0_VENDOR := Raspberry Pi
DEVICE_ALT0_MODEL := 2B-1.2
@@ -148,7 +150,7 @@ ifeq ($(SUBTARGET),bcm2710)
endif
define Device/rpi-4
- DEVICE_MODEL := 4B/400/4CM
+ DEVICE_MODEL := 4B/400/CM4
DEVICE_VARIANT := (64bit)
KERNEL_IMG := kernel8.img
DEVICE_DTS := \
@@ -162,6 +164,7 @@ define Device/rpi-4
DEVICE_PACKAGES := \
cypress-firmware-43455-sdio \
cypress-nvram-43455-sdio-rpi-4b \
+ cypress-nvram-43455-sdio-rpi-cm4 \
kmod-brcmfmac wpad-basic-wolfssl \
kmod-usb-net-lan78xx
IMAGE/sysupgrade.img.gz := boot-common | boot-2711 | sdcard-img | gzip | append-metadata