aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2021-08-21 10:54:34 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2021-08-21 19:07:07 +0200
commit8299d1f057439f94c6a4412e2e5c5082b82a30c9 (patch)
tree1bf678d61f11f7394493be464c7876e496f7faed /target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch
parent33b6885975ce376ff075362b7f0890326043111b (diff)
downloadupstream-8299d1f057439f94c6a4412e2e5c5082b82a30c9.tar.gz
upstream-8299d1f057439f94c6a4412e2e5c5082b82a30c9.tar.bz2
upstream-8299d1f057439f94c6a4412e2e5c5082b82a30c9.zip
bcm27xx: add kernel 5.10 support
Rebased RPi foundation patches on linux 5.10.59, removed applied and reverted patches, wireless patches and defconfig patches. bcm2708: boot tested on RPi B+ v1.2 bcm2709: boot tested on RPi 4B v1.1 4G bcm2711: boot tested on RPi 4B v1.1 4G Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch')
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch100
1 files changed, 100 insertions, 0 deletions
diff --git a/target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch b/target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch
new file mode 100644
index 0000000000..35405ee137
--- /dev/null
+++ b/target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch
@@ -0,0 +1,100 @@
+From 6c6596610381249719e87e324a9689cabc2a7cd8 Mon Sep 17 00:00:00 2001
+From: Phil Elwell <phil@raspberrypi.com>
+Date: Thu, 18 Feb 2021 21:05:44 +0000
+Subject: [PATCH] overlays: Add minipitft13 overlay
+
+minipitft13 is an overlay for the Adafruit 1.3" 240x240 display
+(code 4484).
+
+See: https://github.com/raspberrypi/firmware/issues/1524
+
+Signed-off-by: Phil Elwell <phil@raspberrypi.com>
+---
+ arch/arm/boot/dts/overlays/Makefile | 1 +
+ .../boot/dts/overlays/minipitft13-overlay.dts | 70 +++++++++++++++++++
+ 2 files changed, 71 insertions(+)
+ create mode 100644 arch/arm/boot/dts/overlays/minipitft13-overlay.dts
+
+--- a/arch/arm/boot/dts/overlays/Makefile
++++ b/arch/arm/boot/dts/overlays/Makefile
+@@ -119,6 +119,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
+ merus-amp.dtbo \
+ midi-uart0.dtbo \
+ midi-uart1.dtbo \
++ minipitft13.dtbo \
+ miniuart-bt.dtbo \
+ mmc.dtbo \
+ mpu6050.dtbo \
+--- /dev/null
++++ b/arch/arm/boot/dts/overlays/minipitft13-overlay.dts
+@@ -0,0 +1,70 @@
++/*
++ * Device Tree overlay for Adafruit Mini PiTFT 1.3" and 1.5" 240x240 Display
++ *
++ */
++
++/dts-v1/;
++/plugin/;
++
++/ {
++ compatible = "brcm,bcm2835";
++
++ fragment@0 {
++ target = <&spi0>;
++ __overlay__ {
++ status = "okay";
++
++ spidev@0{
++ status = "disabled";
++ };
++
++ spidev@1{
++ status = "disabled";
++ };
++ };
++ };
++
++ fragment@1 {
++ target = <&gpio>;
++ __overlay__ {
++ pitft_pins: pitft_pins {
++ brcm,pins = <25>;
++ brcm,function = <1>; /* out */
++ brcm,pull = <0>; /* none */
++ };
++ };
++ };
++
++ fragment@2 {
++ target = <&spi0>;
++ __overlay__ {
++ /* needed to avoid dtc warning */
++ #address-cells = <1>;
++ #size-cells = <0>;
++
++ pitft: pitft@0 {
++ compatible = "fbtft,minipitft13";
++ reg = <0>;
++ pinctrl-names = "default";
++ pinctrl-0 = <&pitft_pins>;
++ spi-max-frequency = <32000000>;
++ rotate = <0>;
++ width = <240>;
++ height = <240>;
++ buswidth = <8>;
++ dc-gpios = <&gpio 25 0>;
++ led-gpios = <&gpio 26 0>;
++ debug = <0>;
++ };
++ };
++ };
++
++ __overrides__ {
++ speed = <&pitft>,"spi-max-frequency:0";
++ rotate = <&pitft>,"rotate:0";
++ width = <&pitft>,"width:0";
++ height = <&pitft>,"height:0";
++ fps = <&pitft>,"fps:0";
++ debug = <&pitft>,"debug:0";
++ };
++};