aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/patches-5.10/950-0466-Overlays-for-PiFi-Mini-amp.patch
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2021-08-21 10:54:34 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2021-08-21 19:07:07 +0200
commit8299d1f057439f94c6a4412e2e5c5082b82a30c9 (patch)
tree1bf678d61f11f7394493be464c7876e496f7faed /target/linux/bcm27xx/patches-5.10/950-0466-Overlays-for-PiFi-Mini-amp.patch
parent33b6885975ce376ff075362b7f0890326043111b (diff)
downloadupstream-8299d1f057439f94c6a4412e2e5c5082b82a30c9.tar.gz
upstream-8299d1f057439f94c6a4412e2e5c5082b82a30c9.tar.bz2
upstream-8299d1f057439f94c6a4412e2e5c5082b82a30c9.zip
bcm27xx: add kernel 5.10 support
Rebased RPi foundation patches on linux 5.10.59, removed applied and reverted patches, wireless patches and defconfig patches. bcm2708: boot tested on RPi B+ v1.2 bcm2709: boot tested on RPi 4B v1.1 4G bcm2711: boot tested on RPi 4B v1.1 4G Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm27xx/patches-5.10/950-0466-Overlays-for-PiFi-Mini-amp.patch')
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0466-Overlays-for-PiFi-Mini-amp.patch83
1 files changed, 83 insertions, 0 deletions
diff --git a/target/linux/bcm27xx/patches-5.10/950-0466-Overlays-for-PiFi-Mini-amp.patch b/target/linux/bcm27xx/patches-5.10/950-0466-Overlays-for-PiFi-Mini-amp.patch
new file mode 100644
index 0000000000..24dc00be6a
--- /dev/null
+++ b/target/linux/bcm27xx/patches-5.10/950-0466-Overlays-for-PiFi-Mini-amp.patch
@@ -0,0 +1,83 @@
+From 1040be57555a700e5949aa509299fea40649269e Mon Sep 17 00:00:00 2001
+From: David Knell <david.knell@gmail.com>
+Date: Mon, 8 Feb 2021 03:33:30 +0000
+Subject: [PATCH] Overlays for PiFi-Mini amp
+
+Signed-off-by: David Knell <david.knell@gmail.com>
+---
+ arch/arm/boot/dts/overlays/Makefile | 1 +
+ arch/arm/boot/dts/overlays/README | 6 +++
+ .../dts/overlays/pifi-mini-210-overlay.dts | 42 +++++++++++++++++++
+ 3 files changed, 49 insertions(+)
+ create mode 100644 arch/arm/boot/dts/overlays/pifi-mini-210-overlay.dts
+
+--- a/arch/arm/boot/dts/overlays/Makefile
++++ b/arch/arm/boot/dts/overlays/Makefile
+@@ -130,6 +130,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
+ pibell.dtbo \
+ pifacedigital.dtbo \
+ pifi-40.dtbo \
++ pifi-mini-210.dtbo \
+ piglow.dtbo \
+ piscreen.dtbo \
+ piscreen2r.dtbo \
+--- a/arch/arm/boot/dts/overlays/README
++++ b/arch/arm/boot/dts/overlays/README
+@@ -2131,6 +2131,12 @@ Load: dtoverlay=pifi-40
+ Params: <None>
+
+
++Name: pifi-mini-210
++Info: Configures the PiFi Mini stereo amplifier
++Load: dtoverlay=pifi-mini-210
++Params: <None>
++
++
+ Name: piglow
+ Info: Configures the PiGlow by pimoroni.com
+ Load: dtoverlay=piglow
+--- /dev/null
++++ b/arch/arm/boot/dts/overlays/pifi-mini-210-overlay.dts
+@@ -0,0 +1,42 @@
++// Definitions for PiFi Mini 210
++/dts-v1/;
++/plugin/;
++
++/ {
++ compatible = "brcm,bcm2835";
++
++ fragment@0 {
++ target = <&i2s>;
++ __overlay__ {
++ status = "okay";
++ };
++ };
++
++ fragment@1 {
++ target = <&i2c1>;
++ __overlay__ {
++ #address-cells = <1>;
++ #size-cells = <0>;
++ status = "okay";
++
++ tas5711@1a {
++ #sound-dai-cells = <0>;
++ compatible = "ti,tas5711";
++ reg = <0x1a>;
++ status = "okay";
++ pdn-gpios = <&gpio 23 1>;
++ reset-gpios = <&gpio 24 1>;
++ };
++ };
++ };
++
++ fragment@2 {
++ target = <&sound>;
++ __overlay__ {
++ compatible = "pifi,pifi-mini-210";
++ i2s-controller = <&i2s>;
++
++ status = "okay";
++ };
++ };
++};