aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/patches-4.19/950-0091-Add-arm64-configuration-and-device-tree-differences..patch
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-08 21:58:55 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-14 14:10:51 +0100
commit7d7aa2fd924c27829ec25f825481554dd81bce97 (patch)
tree658b87b89331670266163e522ea5fb52535633cb /target/linux/bcm27xx/patches-4.19/950-0091-Add-arm64-configuration-and-device-tree-differences..patch
parente7bfda2c243e66a75ff966ba04c28b1590b5d24c (diff)
downloadupstream-7d7aa2fd924c27829ec25f825481554dd81bce97.tar.gz
upstream-7d7aa2fd924c27829ec25f825481554dd81bce97.tar.bz2
upstream-7d7aa2fd924c27829ec25f825481554dd81bce97.zip
brcm2708: rename target to bcm27xx
This change makes the names of Broadcom targets consistent by using the common notation based on SoC/CPU ID (which is used internally anyway), bcmXXXX instead of brcmXXXX. This is even used for target TITLE in make menuconfig already, only the short target name used brcm so far. Despite, since subtargets range from bcm2708 to bcm2711, it seems appropriate to use bcm27xx instead of bcm2708 (again, as already done for BOARDNAME). This also renames the packages brcm2708-userland and brcm2708-gpu-fw. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm27xx/patches-4.19/950-0091-Add-arm64-configuration-and-device-tree-differences..patch')
-rw-r--r--target/linux/bcm27xx/patches-4.19/950-0091-Add-arm64-configuration-and-device-tree-differences..patch125
1 files changed, 125 insertions, 0 deletions
diff --git a/target/linux/bcm27xx/patches-4.19/950-0091-Add-arm64-configuration-and-device-tree-differences..patch b/target/linux/bcm27xx/patches-4.19/950-0091-Add-arm64-configuration-and-device-tree-differences..patch
new file mode 100644
index 0000000000..4e49856630
--- /dev/null
+++ b/target/linux/bcm27xx/patches-4.19/950-0091-Add-arm64-configuration-and-device-tree-differences..patch
@@ -0,0 +1,125 @@
+From 9731e002f651c0b386137105c8d91d198b73b721 Mon Sep 17 00:00:00 2001
+From: Michael Zoran <mzoran@crowfest.net>
+Date: Wed, 24 Aug 2016 03:35:56 -0700
+Subject: [PATCH] Add arm64 configuration and device tree differences.
+ Disable MMC_BCM2835_SDHOST and MMC_BCM2835 since these drivers are crashing
+ at the moment.
+
+ARM64: Modify default config to get raspbian to boot (#1686)
+
+1. Enable emulation of deprecated instructions.
+2. Enable ARM 8.1 and 8.2 features which are not detected at runtime.
+3. Switch the default governer to powersave.
+4. Include the watchdog timer driver in the kernel image rather then a module.
+
+Tested with raspbian-jessie 2016-09-23.
+
+ARM64: Make it work again on 4.9 (#1790)
+
+* Invoke the dtc compiler with the same options used in arm mode.
+* ARM64 now uses the bcm2835 platform just like ARM32.
+* ARM64: Update bcmrpi3_defconfig
+
+Signed-off-by: Michael Zoran <mzoran@crowfest.net>
+
+Update arm64 Makefile to compile bcm2710 dtb file
+
+The line 'dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-3-b.dtb' has been copied from previous rpi-4.14.y version into rpi-4.15.y arch/arm64/boot/dts/broadcom/Makefile to restore compilation of bcm2710-rpi-3-b.dtb device tree blob under 'make ARCH=arm64 dtbs' command.
+
+arm64: enable thermal / enable mmc (#2425)
+
+This commit adds support for RP3-B-Plus in in arch arm64 (#2464)
+
+Enable AES, AES bit slice, and AES NEON engines on arm64
+
+Enable bbr module for arm64
+---
+ arch/arm64/Kconfig.platforms | 6 -
+ arch/arm64/boot/dts/Makefile | 2 +
+ arch/arm64/boot/dts/broadcom/Makefile | 3 +
+ .../dts/broadcom/bcm2710-rpi-3-b-plus.dts | 3 +
+ .../boot/dts/broadcom/bcm2710-rpi-3-b.dts | 3 +
+ .../dts/broadcom/bcm283x-rpi-lan7515.dtsi | 1 +
+ arch/arm64/boot/dts/overlays | 1 +
+ 8 files changed, 1302 insertions(+), 6 deletions(-)
+ create mode 100644 arch/arm64/boot/dts/broadcom/bcm2710-rpi-3-b-plus.dts
+ create mode 100644 arch/arm64/boot/dts/broadcom/bcm2710-rpi-3-b.dts
+ create mode 120000 arch/arm64/boot/dts/broadcom/bcm283x-rpi-lan7515.dtsi
+ create mode 120000 arch/arm64/boot/dts/overlays
+
+diff --git a/arch/arm64/Kconfig.platforms b/arch/arm64/Kconfig.platforms
+index 393d2b524284..e9bdec0ead72 100644
+--- a/arch/arm64/Kconfig.platforms
++++ b/arch/arm64/Kconfig.platforms
+@@ -1,11 +1,5 @@
+ menu "Platform selection"
+
+-config ARCH_ACTIONS
+- bool "Actions Semi Platforms"
+- select OWL_TIMER
+- help
+- This enables support for the Actions Semiconductor S900 SoC family.
+-
+ config ARCH_SUNXI
+ bool "Allwinner sunxi 64-bit SoC Family"
+ select ARCH_HAS_RESET_CONTROLLER
+diff --git a/arch/arm64/boot/dts/Makefile b/arch/arm64/boot/dts/Makefile
+index 4690364d584b..cd9c79566ebe 100644
+--- a/arch/arm64/boot/dts/Makefile
++++ b/arch/arm64/boot/dts/Makefile
+@@ -26,3 +26,5 @@ subdir-y += synaptics
+ subdir-y += ti
+ subdir-y += xilinx
+ subdir-y += zte
++
++subdir-y += overlays
+diff --git a/arch/arm64/boot/dts/broadcom/Makefile b/arch/arm64/boot/dts/broadcom/Makefile
+index 1193a9e34bbb..78d23305bc31 100644
+--- a/arch/arm64/boot/dts/broadcom/Makefile
++++ b/arch/arm64/boot/dts/broadcom/Makefile
+@@ -1,6 +1,9 @@
+ # SPDX-License-Identifier: GPL-2.0
+ dtb-$(CONFIG_ARCH_BCM2835) += bcm2837-rpi-3-b.dtb \
+ bcm2837-rpi-3-b-plus.dtb
++dtb-$(CONFIG_ARCH_BCM2709) += bcm2710-rpi-3-b.dtb
++dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-3-b.dtb
++dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-3-b-plus.dtb
+
+ subdir-y += northstar2
+ subdir-y += stingray
+diff --git a/arch/arm64/boot/dts/broadcom/bcm2710-rpi-3-b-plus.dts b/arch/arm64/boot/dts/broadcom/bcm2710-rpi-3-b-plus.dts
+new file mode 100644
+index 000000000000..d9242ff77079
+--- /dev/null
++++ b/arch/arm64/boot/dts/broadcom/bcm2710-rpi-3-b-plus.dts
+@@ -0,0 +1,3 @@
++#define RPI364
++
++#include "../../../../arm/boot/dts/bcm2710-rpi-3-b-plus.dts"
+diff --git a/arch/arm64/boot/dts/broadcom/bcm2710-rpi-3-b.dts b/arch/arm64/boot/dts/broadcom/bcm2710-rpi-3-b.dts
+new file mode 100644
+index 000000000000..deb33441da95
+--- /dev/null
++++ b/arch/arm64/boot/dts/broadcom/bcm2710-rpi-3-b.dts
+@@ -0,0 +1,3 @@
++#define RPI364
++
++#include "../../../../arm/boot/dts/bcm2710-rpi-3-b.dts"
+diff --git a/arch/arm64/boot/dts/broadcom/bcm283x-rpi-lan7515.dtsi b/arch/arm64/boot/dts/broadcom/bcm283x-rpi-lan7515.dtsi
+new file mode 120000
+index 000000000000..fc4c05bbe7fd
+--- /dev/null
++++ b/arch/arm64/boot/dts/broadcom/bcm283x-rpi-lan7515.dtsi
+@@ -0,0 +1 @@
++../../../../arm/boot/dts/bcm283x-rpi-lan7515.dtsi
+\ No newline at end of file
+diff --git a/arch/arm64/boot/dts/overlays b/arch/arm64/boot/dts/overlays
+new file mode 120000
+index 000000000000..ded08646b6f6
+--- /dev/null
++++ b/arch/arm64/boot/dts/overlays
+@@ -0,0 +1 @@
++../../../arm/boot/dts/overlays
+\ No newline at end of file
+--
+2.20.1