aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/modules
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2022-05-17 15:02:39 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2022-05-17 15:11:23 +0200
commitd5c4f24b2af991df2ec24df1a3f906049370f59f (patch)
tree640c4a349a2fce2b7dbee7ed0115726bd5d9c245 /target/linux/bcm27xx/modules
parent99ad84b6d9727a63f99a16e0b8386747262e3433 (diff)
downloadupstream-d5c4f24b2af991df2ec24df1a3f906049370f59f.tar.gz
upstream-d5c4f24b2af991df2ec24df1a3f906049370f59f.tar.bz2
upstream-d5c4f24b2af991df2ec24df1a3f906049370f59f.zip
bcm27xx: remove linux 5.10 compatibility
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm27xx/modules')
-rw-r--r--target/linux/bcm27xx/modules/hwmon.mk16
-rw-r--r--target/linux/bcm27xx/modules/sound.mk2
-rw-r--r--target/linux/bcm27xx/modules/video.mk2
3 files changed, 2 insertions, 18 deletions
diff --git a/target/linux/bcm27xx/modules/hwmon.mk b/target/linux/bcm27xx/modules/hwmon.mk
index 02ac204e1a..0f1547cd4f 100644
--- a/target/linux/bcm27xx/modules/hwmon.mk
+++ b/target/linux/bcm27xx/modules/hwmon.mk
@@ -15,19 +15,3 @@ define KernelPackage/hwmon-raspberrypi/description
endef
$(eval $(call KernelPackage,hwmon-raspberrypi))
-
-
-define KernelPackage/hwmon-rpi-poe-fan
- SUBMENU:=$(HWMON_MENU)
- TITLE:=Raspberry Pi PoE HAT fan
- DEPENDS:=@TARGET_bcm27xx @LINUX_5_10 +kmod-hwmon-core
- KCONFIG:=CONFIG_SENSORS_RPI_POE_FAN
- FILES:=$(LINUX_DIR)/drivers/hwmon/rpi-poe-fan.ko
- AUTOLOAD:=$(call AutoProbe,rpi-poe-fan)
-endef
-
-define KernelPackage/hwmon-rpi-poe-fan/description
- Raspberry Pi PoE HAT fan driver
-endef
-
-$(eval $(call KernelPackage,hwmon-rpi-poe-fan))
diff --git a/target/linux/bcm27xx/modules/sound.mk b/target/linux/bcm27xx/modules/sound.mk
index f6372f6870..3d5ba33626 100644
--- a/target/linux/bcm27xx/modules/sound.mk
+++ b/target/linux/bcm27xx/modules/sound.mk
@@ -932,7 +932,7 @@ define KernelPackage/sound-soc-rpi-cirrus
CONFIG_SND_SOC_WM8804 \
CONFIG_SND_SOC_WM_ADSP
FILES:= \
- $(LINUX_DIR)/drivers/mfd/arizona.ko@ge5.15 \
+ $(LINUX_DIR)/drivers/mfd/arizona.ko \
$(LINUX_DIR)/sound/soc/bcm/snd-soc-rpi-cirrus.ko \
$(LINUX_DIR)/sound/soc/codecs/snd-soc-arizona.ko \
$(LINUX_DIR)/sound/soc/codecs/snd-soc-wm-adsp.ko \
diff --git a/target/linux/bcm27xx/modules/video.mk b/target/linux/bcm27xx/modules/video.mk
index f480831caf..f9d32e263a 100644
--- a/target/linux/bcm27xx/modules/video.mk
+++ b/target/linux/bcm27xx/modules/video.mk
@@ -40,7 +40,7 @@ define KernelPackage/drm-vc4
$(LINUX_DIR)/drivers/gpu/drm/vc4/vc4.ko \
$(LINUX_DIR)/drivers/gpu/drm/drm_kms_helper.ko \
$(LINUX_DIR)/drivers/media/cec/cec.ko@lt5.10 \
- $(LINUX_DIR)/drivers/media/cec/core/cec.ko@ge5.10
+ $(LINUX_DIR)/drivers/media/cec/core/cec.ko
AUTOLOAD:=$(call AutoProbe,vc4)
endef