aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/modules
diff options
context:
space:
mode:
authorTorsten Duwe <duwe@lst.de>2021-09-22 10:52:51 +0200
committerPetr Štetiar <ynezz@true.cz>2022-04-16 14:55:27 +0200
commit41a97c207438903c309371ba695cea01ae78aba4 (patch)
tree1759a95a102f0545aa48fac06b91d7cdfbfa4de2 /target/linux/bcm27xx/modules
parent9a765554f409235ff6359d6eccb79187c2513de0 (diff)
downloadupstream-41a97c207438903c309371ba695cea01ae78aba4.tar.gz
upstream-41a97c207438903c309371ba695cea01ae78aba4.tar.bz2
upstream-41a97c207438903c309371ba695cea01ae78aba4.zip
bcm27xx: add AMP2 to HifiBerry DAC+ / DAC+ Pro package
According to the vendor [1] these HATs share the same DT overlay: hifiberry-dacplus. The PCM512x-compatible control unit is attached to I2C, so the additional snd-soc-pcm512x-i2c kernel module is required. Also explicitly note the Amp2 support to reduce confusion for those users. [1] <https://www.hifiberry.com/docs/software/configuring-linux-3-18-x/> Signed-off-by: Torsten Duwe <duwe@lst.de> (added bcm27xx tag, changed commit message) Signed-off-by: Christian Lamparter <chunkeey@gmail.com> (cherry picked from commit 7ea9936f7f32fd90af1a29775ac3b297d7775db7)
Diffstat (limited to 'target/linux/bcm27xx/modules')
-rw-r--r--target/linux/bcm27xx/modules/sound.mk15
1 files changed, 9 insertions, 6 deletions
diff --git a/target/linux/bcm27xx/modules/sound.mk b/target/linux/bcm27xx/modules/sound.mk
index dab31d8132..1d3165ed2f 100644
--- a/target/linux/bcm27xx/modules/sound.mk
+++ b/target/linux/bcm27xx/modules/sound.mk
@@ -509,24 +509,27 @@ $(eval $(call KernelPackage,sound-soc-hifiberry-dac))
define KernelPackage/sound-soc-hifiberry-dacplus
- TITLE:=Support for HifiBerry DAC+ / DAC+ Pro
+ TITLE:=Support for HifiBerry DAC+ / DAC+ Pro / Amp2
KCONFIG:= \
CONFIG_SND_BCM2708_SOC_HIFIBERRY_DACPLUS \
- CONFIG_SND_SOC_PCM512x
+ CONFIG_SND_SOC_PCM512x \
+ CONFIG_SND_SOC_PCM512x_I2C
FILES:= \
$(LINUX_DIR)/drivers/clk/clk-hifiberry-dacpro.ko \
$(LINUX_DIR)/sound/soc/bcm/snd-soc-hifiberry-dacplus.ko \
- $(LINUX_DIR)/sound/soc/codecs/snd-soc-pcm512x.ko
+ $(LINUX_DIR)/sound/soc/codecs/snd-soc-pcm512x.ko \
+ $(LINUX_DIR)/sound/soc/codecs/snd-soc-pcm512x-i2c.ko
AUTOLOAD:=$(call AutoLoad,68,clk-hifiberry-dacpro snd-soc-pcm512x \
- snd-soc-hifiberry-dacplus)
+ snd-soc-pcm512x-i2c snd-soc-hifiberry-dacplus)
DEPENDS:= \
kmod-sound-soc-bcm2835-i2s \
- +kmod-i2c-bcm2835
+ +kmod-i2c-bcm2835 \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
define KernelPackage/sound-soc-hifiberry-dacplus/description
- This package contains support for HifiBerry DAC+ / DAC+ Pro
+ This package contains support for HifiBerry DAC+ / DAC+ Pro / Amp2
endef
$(eval $(call KernelPackage,sound-soc-hifiberry-dacplus))