aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/modules/sound.mk
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-04 22:47:27 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 13:02:44 +0200
commit047361dee44cab2b2355f7b7859fd688f6483cbc (patch)
treec025ae837defcf9cd9afd3d11a1b2930ac5fe9f6 /target/linux/bcm27xx/modules/sound.mk
parentd798617d4aded6b922764bd5fea8651e12206afe (diff)
downloadupstream-047361dee44cab2b2355f7b7859fd688f6483cbc.tar.gz
upstream-047361dee44cab2b2355f7b7859fd688f6483cbc.tar.bz2
upstream-047361dee44cab2b2355f7b7859fd688f6483cbc.zip
treewide: cleanup kernel symbol references
We only use 5.15 kernel. So remove all those unnecessary symbols referencing 5.10 or 5.15 kernel. Can be found with: git grep -E 'LINUX_5_1(0|5)' Note that we remove the dependency from "sound-soc-chipdip-dac" instead of removing the complete kernel package. The 5.15 version bump forgot to delete the "@LINUX_5_10" dependency. The kernel package is still needed in 5.15 kernel. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target/linux/bcm27xx/modules/sound.mk')
-rw-r--r--target/linux/bcm27xx/modules/sound.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/bcm27xx/modules/sound.mk b/target/linux/bcm27xx/modules/sound.mk
index 182d80a2c8..47c0a93879 100644
--- a/target/linux/bcm27xx/modules/sound.mk
+++ b/target/linux/bcm27xx/modules/sound.mk
@@ -371,8 +371,7 @@ define KernelPackage/sound-soc-chipdip-dac
$(LINUX_DIR)/sound/soc/bcm/snd-soc-chipdip-dac.ko
AUTOLOAD:=$(call AutoLoad,68,snd-soc-chipdip-dac)
DEPENDS:= \
- kmod-sound-soc-bcm2835-i2s \
- @LINUX_5_10
+ kmod-sound-soc-bcm2835-i2s
$(call AddDepends/sound)
endef