aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/modules/sound.mk
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2021-08-21 10:54:34 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2021-08-21 19:07:07 +0200
commit8299d1f057439f94c6a4412e2e5c5082b82a30c9 (patch)
tree1bf678d61f11f7394493be464c7876e496f7faed /target/linux/bcm27xx/modules/sound.mk
parent33b6885975ce376ff075362b7f0890326043111b (diff)
downloadupstream-8299d1f057439f94c6a4412e2e5c5082b82a30c9.tar.gz
upstream-8299d1f057439f94c6a4412e2e5c5082b82a30c9.tar.bz2
upstream-8299d1f057439f94c6a4412e2e5c5082b82a30c9.zip
bcm27xx: add kernel 5.10 support
Rebased RPi foundation patches on linux 5.10.59, removed applied and reverted patches, wireless patches and defconfig patches. bcm2708: boot tested on RPi B+ v1.2 bcm2709: boot tested on RPi 4B v1.1 4G bcm2711: boot tested on RPi 4B v1.1 4G Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm27xx/modules/sound.mk')
-rw-r--r--target/linux/bcm27xx/modules/sound.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/bcm27xx/modules/sound.mk b/target/linux/bcm27xx/modules/sound.mk
index dab31d8132..5073e5ff50 100644
--- a/target/linux/bcm27xx/modules/sound.mk
+++ b/target/linux/bcm27xx/modules/sound.mk
@@ -365,6 +365,26 @@ endef
$(eval $(call KernelPackage,sound-soc-audioinjector-pi-soundcard))
+define KernelPackage/sound-soc-chipdip-dac
+ TITLE:=Support for ChipDip DAC
+ KCONFIG:= \
+ CONFIG_SND_BCM2708_SOC_CHIPDIP_DAC
+ FILES:= \
+ $(LINUX_DIR)/sound/soc/bcm/snd-soc-chipdip-dac.ko
+ AUTOLOAD:=$(call AutoLoad,68,snd-soc-chipdip-dac)
+ DEPENDS:= \
+ kmod-sound-soc-bcm2835-i2s \
+ @LINUX_5_10
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-chipdip-dac/description
+ This package contains support for ChipDip DAC
+endef
+
+$(eval $(call KernelPackage,sound-soc-chipdip-dac))
+
+
define KernelPackage/sound-soc-digidac1-soundcard
TITLE:=Support for RRA DigiDAC1
KCONFIG:= \