aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-08 21:58:55 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-14 14:10:51 +0100
commit7d7aa2fd924c27829ec25f825481554dd81bce97 (patch)
tree658b87b89331670266163e522ea5fb52535633cb /target/linux/bcm27xx/Makefile
parente7bfda2c243e66a75ff966ba04c28b1590b5d24c (diff)
downloadupstream-7d7aa2fd924c27829ec25f825481554dd81bce97.tar.gz
upstream-7d7aa2fd924c27829ec25f825481554dd81bce97.tar.bz2
upstream-7d7aa2fd924c27829ec25f825481554dd81bce97.zip
brcm2708: rename target to bcm27xx
This change makes the names of Broadcom targets consistent by using the common notation based on SoC/CPU ID (which is used internally anyway), bcmXXXX instead of brcmXXXX. This is even used for target TITLE in make menuconfig already, only the short target name used brcm so far. Despite, since subtargets range from bcm2708 to bcm2711, it seems appropriate to use bcm27xx instead of bcm2708 (again, as already done for BOARDNAME). This also renames the packages brcm2708-userland and brcm2708-gpu-fw. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm27xx/Makefile')
-rw-r--r--target/linux/bcm27xx/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/bcm27xx/Makefile b/target/linux/bcm27xx/Makefile
new file mode 100644
index 0000000000..8976a43609
--- /dev/null
+++ b/target/linux/bcm27xx/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2012-2019 OpenWrt.org
+# Copyright (C) 2017 LEDE project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=bcm27xx
+BOARDNAME:=Broadcom BCM27xx
+FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs rootfs-part boot-part
+MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
+SUBTARGETS:=bcm2708 bcm2709 bcm2710 bcm2711
+
+KERNEL_PATCHVER:=4.19
+
+define Target/Description
+ Build firmware image for Broadcom BCM27xx SoC devices.
+ Currently produces SD Card image for Raspberry Pi.
+endef
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+ bcm27xx-gpu-fw \
+ kmod-usb-hid \
+ kmod-sound-core kmod-sound-arm-bcm2835 \
+ kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
+ partx-utils mkf2fs e2fsprogs
+
+KERNELNAME:=Image dtbs
+
+$(eval $(call BuildTarget))