aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-03-12 13:28:16 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-03-12 13:28:16 +0000
commit73caeba5228e8404381cea1f550dfbde099b910b (patch)
treee61704d04c9934b344ec4f5443462d8ca0d6ab1e /target/linux/avr32
parent12a213227e348a722f1ee6928434ea9708e0cead (diff)
downloadupstream-73caeba5228e8404381cea1f550dfbde099b910b.tar.gz
upstream-73caeba5228e8404381cea1f550dfbde099b910b.tar.bz2
upstream-73caeba5228e8404381cea1f550dfbde099b910b.zip
avr32: built the firmware images from the lzma compressed uImage
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35978
Diffstat (limited to 'target/linux/avr32')
-rw-r--r--target/linux/avr32/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index 595a5d9fcf..11387b14ea 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -40,14 +40,14 @@ endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
( \
- dd if=$(KDIR)/uImage bs=1024k conv=sync; \
+ dd if=$(KDIR)/uImage-lzma bs=1024k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
endef
define Image/Build/jffs2-64k
( \
- dd if=$(KDIR)/uImage bs=1024k conv=sync; \
+ dd if=$(KDIR)/uImage-lzma bs=1024k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
endef