aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit6a4f2922f6303a006d66b4bbb79541823b1c12b4 (patch)
treed3d9644c2a4a2e9b758bab9b84973e078143ed2c /target/linux/avr32
parenteab95ea46736f8359c5a19a612f0e39160cab80c (diff)
downloadupstream-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.gz
upstream-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.bz2
upstream-6a4f2922f6303a006d66b4bbb79541823b1c12b4.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 37049
Diffstat (limited to 'target/linux/avr32')
-rw-r--r--target/linux/avr32/Makefile2
-rw-r--r--target/linux/avr32/image/Makefile4
2 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/avr32/Makefile b/target/linux/avr32/Makefile
index 55cff25561..83b67b61eb 100644
--- a/target/linux/avr32/Makefile
+++ b/target/linux/avr32/Makefile
@@ -20,4 +20,6 @@ define Target/Description
Build firmware images for ATNGW100 board
endef
+KERNELNAME:="uImage"
+
$(eval $(call BuildTarget))
diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index 11387b14ea..ad53572dba 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -17,10 +17,6 @@ ifneq ($(CONFIG_AVR32_UBOOT),)
endef
endif
-define Image/Prepare
- cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage
-endef
-
define Image/BuildKernel
cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage