aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-25 19:32:34 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-25 19:32:34 +0000
commit942e69b1663cf74a172df4f5e370d59d0798c081 (patch)
tree7f13ba0e858a0bb18b03d9e71710f9e9f2a910d1 /target/linux/avr32/image
parent11e4e6ebfbc536b06cb3ff6a63c2962026df36dc (diff)
downloadupstream-942e69b1663cf74a172df4f5e370d59d0798c081.tar.gz
upstream-942e69b1663cf74a172df4f5e370d59d0798c081.tar.bz2
upstream-942e69b1663cf74a172df4f5e370d59d0798c081.zip
avr32: optimize image generation
- remove the kernel+rootfs partitions from the MTD partition map, - use a temporary directory for intermediate image files, - append the root squashfs directly to the kernel, - don't hardcode uImage size in the jffs2 images, Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38194
Diffstat (limited to 'target/linux/avr32/image')
-rw-r--r--target/linux/avr32/image/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index ad53572dba..99761c6da5 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -7,6 +7,8 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+KDIR_TMP:=$(KDIR)/tmp
+
ifneq ($(CONFIG_AVR32_UBOOT),)
define Build/Clean
$(MAKE) -C u-boot clean
@@ -18,6 +20,7 @@ ifneq ($(CONFIG_AVR32_UBOOT),)
endif
define Image/BuildKernel
+ -mkdir -p $(KDIR_TMP)
cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
$(STAGING_DIR_HOST)/bin/lzma e $(LINUX_DIR)/arch/avr32/boot/images/vmlinux.bin $(KDIR)/vmlinux.lzma
@@ -34,16 +37,17 @@ define Image/Build
endef
define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
( \
- dd if=$(KDIR)/uImage-lzma bs=1024k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
+ cat $(KDIR)/uImage-lzma; \
+ cat $(KDIR)/root.squashfs; \
+ ) > $(KDIR_TMP)/avr32-squahsfs.img
+ padjffs2 $(KDIR_TMP)/avr32-squahsfs.img 64
+ dd if=$(KDIR_TMP)/avr32-squahsfs.img of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=64k conv=sync
endef
define Image/Build/jffs2-64k
( \
- dd if=$(KDIR)/uImage-lzma bs=1024k conv=sync; \
+ dd if=$(KDIR)/uImage-lzma bs=64k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
endef