aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32/image/u-boot/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-24 10:06:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-24 10:06:14 +0000
commit2450985de9b4e47c77b57c1fd9469d43d1c43636 (patch)
treece96457648a0faf068fb53892bf322ab5a0c749c /target/linux/avr32/image/u-boot/Makefile
parent3b6c70b7fc07627510d236833446a928c6bcbe61 (diff)
downloadupstream-2450985de9b4e47c77b57c1fd9469d43d1c43636.tar.gz
upstream-2450985de9b4e47c77b57c1fd9469d43d1c43636.tar.bz2
upstream-2450985de9b4e47c77b57c1fd9469d43d1c43636.zip
avr32: remove target
It depends on obsolete compilers and only works on one device (an evaluation board). Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44956
Diffstat (limited to 'target/linux/avr32/image/u-boot/Makefile')
-rw-r--r--target/linux/avr32/image/u-boot/Makefile35
1 files changed, 0 insertions, 35 deletions
diff --git a/target/linux/avr32/image/u-boot/Makefile b/target/linux/avr32/image/u-boot/Makefile
deleted file mode 100644
index 6775d1d7c3..0000000000
--- a/target/linux/avr32/image/u-boot/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-#
-# Copyright (C) 2008-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=u-boot
-PKG_VERSION:=2011.06
-PKG_RELEASE:=1
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=0cc5026aad02f218a9b9ac56b301c97a
-PKG_CAT:=bzcat
-
-include $(INCLUDE_DIR)/package.mk
-
-UBOOT_CONFIG=$(call qstrip,$(CONFIG_AVR32_UBOOT_TARGET))
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
- $(MAKE) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS)
-endef
-
-define Build/InstallDev
- mkdir -p $(BIN_DIR)
- dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(BIN_DIR)/u-boot-$(PKG_VERSION)-$(UBOOT_CONFIG).bin bs=64k conv=sync
-endef
-
-$(eval $(call Build/DefaultTargets))