aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-04-28 14:10:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-04-28 14:10:09 +0000
commit8c1d1ccac799f4bd20618ceb327c9488ed051314 (patch)
treefbfbdc7e0cb6b00c577618049593602d208d1bc0 /target/linux/avr32/image/Makefile
parent20f1f851b4955613f737af5763201e1b1064b6ad (diff)
downloadupstream-8c1d1ccac799f4bd20618ceb327c9488ed051314.tar.gz
upstream-8c1d1ccac799f4bd20618ceb327c9488ed051314.tar.bz2
upstream-8c1d1ccac799f4bd20618ceb327c9488ed051314.zip
enable optional building of u-boot for avr32
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10961 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/avr32/image/Makefile')
-rw-r--r--target/linux/avr32/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index 3568984189..cbaf07dfb3 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -4,9 +4,18 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define Build/Clean
+ $(MAKE) -C u-boot clean
+endef
+
+define Build/Compile
+ $(MAKE) -C u-boot compile
+endef
+
define Image/Prepare
cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage
endef