aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32-2.6/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-06-08 10:44:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-06-08 10:44:01 +0000
commit08c72656130891389229ca29e455e08bc735ce1f (patch)
treef32a71704a40c818fa3ea64efa0aefefc4196a8b /target/linux/avr32-2.6/image/Makefile
parent6fb68cb589d76499f5da5902dd83c87722a228f5 (diff)
downloadupstream-08c72656130891389229ca29e455e08bc735ce1f.tar.gz
upstream-08c72656130891389229ca29e455e08bc735ce1f.tar.bz2
upstream-08c72656130891389229ca29e455e08bc735ce1f.zip
add support for the AVR32 platform, namely the ATNGW100 board - joint work with wigyori
SVN-Revision: 7533
Diffstat (limited to 'target/linux/avr32-2.6/image/Makefile')
-rw-r--r--target/linux/avr32-2.6/image/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/target/linux/avr32-2.6/image/Makefile b/target/linux/avr32-2.6/image/Makefile
new file mode 100644
index 0000000000..a001097c58
--- /dev/null
+++ b/target/linux/avr32-2.6/image/Makefile
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ ( \
+ dd if=$(KDIR)/uImage bs=1024k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+endef
+
+define Image/Build/jffs2-64k
+ ( \
+ dd if=$(KDIR)/uImage bs=1024k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+endef
+
+$(eval $(call BuildImage))