aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32-2.6/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-06-08 10:44:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-06-08 10:44:01 +0000
commit08c72656130891389229ca29e455e08bc735ce1f (patch)
treef32a71704a40c818fa3ea64efa0aefefc4196a8b /target/linux/avr32-2.6/Makefile
parent6fb68cb589d76499f5da5902dd83c87722a228f5 (diff)
downloadupstream-08c72656130891389229ca29e455e08bc735ce1f.tar.gz
upstream-08c72656130891389229ca29e455e08bc735ce1f.tar.bz2
upstream-08c72656130891389229ca29e455e08bc735ce1f.zip
add support for the AVR32 platform, namely the ATNGW100 board - joint work with wigyori
SVN-Revision: 7533
Diffstat (limited to 'target/linux/avr32-2.6/Makefile')
-rw-r--r--target/linux/avr32-2.6/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/avr32-2.6/Makefile b/target/linux/avr32-2.6/Makefile
new file mode 100644
index 0000000000..2dcd76a9b4
--- /dev/null
+++ b/target/linux/avr32-2.6/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=avr32
+BOARD:=avr32
+BOARDNAME:=Atmel AVR32
+FEATURES:=squashfs
+
+define Target/Description
+ Build firmware images for ATNGW100 board
+endef
+
+KERNEL:=2.6
+
+include $(INCLUDE_DIR)/kernel-build.mk
+
+#include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))