aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000-2.6
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
commit593b560d9371a5203c60e7e3161d86a65c2b9bb1 (patch)
treef560743479e4aef6d9013643b9b26923cd248bc1 /target/linux/au1000-2.6
parent6206e865143b2b17f2bdb9e9584e3259b7edc4f2 (diff)
downloadupstream-593b560d9371a5203c60e7e3161d86a65c2b9bb1.tar.gz
upstream-593b560d9371a5203c60e7e3161d86a65c2b9bb1.tar.bz2
upstream-593b560d9371a5203c60e7e3161d86a65c2b9bb1.zip
split out profile definitions from Makefiles
structure is as follows: target/linux/<arch>/profiles/<profilename>.mk These files are included by a blob match in the target Makefile The files should be labeled based on their profile Name in the definition git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6468 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/au1000-2.6')
-rw-r--r--target/linux/au1000-2.6/Makefile19
-rw-r--r--target/linux/au1000-2.6/profiles/Atheros.mk13
-rw-r--r--target/linux/au1000-2.6/profiles/Broadcom.mk13
-rw-r--r--target/linux/au1000-2.6/profiles/Intel.mk13
4 files changed, 41 insertions, 17 deletions
diff --git a/target/linux/au1000-2.6/Makefile b/target/linux/au1000-2.6/Makefile
index 25fc776129..30259d55b7 100644
--- a/target/linux/au1000-2.6/Makefile
+++ b/target/linux/au1000-2.6/Makefile
@@ -25,23 +25,8 @@ define Kernel/BuildImage
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
endef
-define Profile/Atheros
- NAME:=Atheros WiFi (default)
- PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/Intel
- NAME:=Intel IPW2200 WiFi
- PACKAGES:=kmod-net-ipw2200
-endef
-$(eval $(call Profile,Intel))
-
-define Profile/Broadcom
- NAME:=Broadcom BCM43xx WiFi
- PACKAGES:=kmod-net-bcm43xx
-endef
-$(eval $(call Profile,Broadcom))
+# include the profiles
+-include profiles/*.mk
$(eval $(call BuildKernel))
diff --git a/target/linux/au1000-2.6/profiles/Atheros.mk b/target/linux/au1000-2.6/profiles/Atheros.mk
new file mode 100644
index 0000000000..ec6e175e80
--- /dev/null
+++ b/target/linux/au1000-2.6/profiles/Atheros.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/au1000-2.6/profiles/Broadcom.mk b/target/linux/au1000-2.6/profiles/Broadcom.mk
new file mode 100644
index 0000000000..d7fb9cb809
--- /dev/null
+++ b/target/linux/au1000-2.6/profiles/Broadcom.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom
+ NAME:=Broadcom BCM43xx WiFi
+ PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
diff --git a/target/linux/au1000-2.6/profiles/Intel.mk b/target/linux/au1000-2.6/profiles/Intel.mk
new file mode 100644
index 0000000000..be112eea91
--- /dev/null
+++ b/target/linux/au1000-2.6/profiles/Intel.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Intel
+ NAME:=Intel IPW2200 WiFi
+ PACKAGES:=kmod-net-ipw2200
+endef
+$(eval $(call Profile,Intel))
+