aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000-2.6/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-05-24 21:57:34 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-05-24 21:57:34 +0000
commit46f7d89f9cafe635d8d3abae28a78927ce2fd63d (patch)
treef35fe52cb93cd8b1250b262129a00a082f27e89b /target/linux/au1000-2.6/image/Makefile
parent41e092a905d0a75eaddeaf61521a4fd5b951930b (diff)
downloadupstream-46f7d89f9cafe635d8d3abae28a78927ce2fd63d.tar.gz
upstream-46f7d89f9cafe635d8d3abae28a78927ce2fd63d.tar.bz2
upstream-46f7d89f9cafe635d8d3abae28a78927ce2fd63d.zip
Update au1000 for .21, build an SREC initramfs image so that it can be tested directly with yamon
SVN-Revision: 7333
Diffstat (limited to 'target/linux/au1000-2.6/image/Makefile')
-rw-r--r--target/linux/au1000-2.6/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/au1000-2.6/image/Makefile b/target/linux/au1000-2.6/image/Makefile
index b5ba3d4542..5b8c3cc0f0 100644
--- a/target/linux/au1000-2.6/image/Makefile
+++ b/target/linux/au1000-2.6/image/Makefile
@@ -48,12 +48,19 @@ define Image/Prepare
$(OBJCOPY_BIN) $(KDIR)/loader_flash.elf $(KDIR)/kernel.flash.bin
endef
+define Image/Build/Initramfs
+ $(OBJCOPY_SREC) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.srec
+endef
+
define Image/Build
$(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma $(FLASH_FS) $(KDIR)/root.$(1) $(KDIR)/root.$(1).srec
grep -v S7 $(KDIR)/root.$(1).srec > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
grep -v S0 $(KDIR)/kernel.flash.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
$(CP) $(KDIR)/kernel.flash.bin $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.bin
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).fs
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+ $(call Image/Build/Initramfs)
+endif
endef
$(eval $(call BuildImage))