aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-09 18:25:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-09 18:25:51 +0000
commitcf3adeaa22cc1b5871b85ceebf2a89bbbe4e5b5d (patch)
tree66428273a98502aba9a19fe47532d62fdba6db39 /target/linux/atheros
parentbba5f37bb87f143c10e9cd96af2263d7cd1302f0 (diff)
downloadupstream-cf3adeaa22cc1b5871b85ceebf2a89bbbe4e5b5d.tar.gz
upstream-cf3adeaa22cc1b5871b85ceebf2a89bbbe4e5b5d.tar.bz2
upstream-cf3adeaa22cc1b5871b85ceebf2a89bbbe4e5b5d.zip
atheros: enable CONFIG_IP17XX_PHY to add back switch support for the DIR-300
SVN-Revision: 26553
Diffstat (limited to 'target/linux/atheros')
-rw-r--r--target/linux/atheros/config-2.6.371
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/atheros/config-2.6.37 b/target/linux/atheros/config-2.6.37
index cb093dc973..739efc7b16 100644
--- a/target/linux/atheros/config-2.6.37
+++ b/target/linux/atheros/config-2.6.37
@@ -73,6 +73,7 @@ CONFIG_HAVE_KRETPROBES=y
CONFIG_HAVE_OPROFILE=y
CONFIG_HW_HAS_PCI=y
CONFIG_HW_RANDOM=y
+CONFIG_IP17XX_PHY=y
CONFIG_IMAGE_CMDLINE_HACK=y
CONFIG_INITRAMFS_SOURCE=""
CONFIG_IRQ_CPU=y
String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
#
# Copyright (C) 2008-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk

ARCH:=powerpc
BOARD:=ppc40x
BOARDNAME:=AMCC/IBM PPC40x
FEATURES:=squashfs
CPU_TYPE:=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>

LINUX_VERSION:=3.10.26

include $(INCLUDE_DIR)/target.mk

define Target/Description
	Build firmware images for AMCC/IBM PPC40x based boards.
endef

KERNELNAME:="uImage cuImage.magicbox cuImage.openrb"

$(eval $(call BuildTarget))