aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-22 19:45:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-22 19:45:14 +0000
commitd6b4535d18cee02c32c53583280bc04afe4b1ebf (patch)
tree948b0bc5786340266168e51bb08beb8fa7e456e4 /target/linux/atheros
parentc27b9bf6db7c1a9ac0593ff8ffcbff10816b9fd0 (diff)
downloadupstream-d6b4535d18cee02c32c53583280bc04afe4b1ebf.tar.gz
upstream-d6b4535d18cee02c32c53583280bc04afe4b1ebf.tar.bz2
upstream-d6b4535d18cee02c32c53583280bc04afe4b1ebf.zip
create firmware image for the Compex NP25G and WPE53G boards
SVN-Revision: 13318
Diffstat (limited to 'target/linux/atheros')
-rw-r--r--target/linux/atheros/image/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index 343e2dedf7..6df21c773e 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -32,6 +32,16 @@ define Image/Build
-v XS5.ar2313.OpenWRT \
-o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin \
-s 0xBE030000
+
+ -$(STAGING_DIR_HOST)/bin/mkmylofw -B np25g \
+ -p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz \
+ -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+ $(BIN_DIR)/openwrt-$(BOARD)-np25g-$(1).bin
+ -$(STAGING_DIR_HOST)/bin/mkmylofw -B wpe53g \
+ -p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz \
+ -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+ $(BIN_DIR)/openwrt-$(BOARD)-wpe53g-$(1).bin
+
endef
$(eval $(call BuildImage))