aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-3.18/101-early-printk-support.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-13 03:02:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-13 03:02:08 +0000
commited8cdc3f8de75be7351db4172937c79fbf6f949b (patch)
tree7c7177266b48183d52ec22f549bcf454f66e0155 /target/linux/atheros/patches-3.18/101-early-printk-support.patch
parentdae90fc1300781065357538943552884d682c1ae (diff)
downloadupstream-ed8cdc3f8de75be7351db4172937c79fbf6f949b.tar.gz
upstream-ed8cdc3f8de75be7351db4172937c79fbf6f949b.tar.bz2
upstream-ed8cdc3f8de75be7351db4172937c79fbf6f949b.zip
atheros: v3.18: renumber backported patches
Move first 3 patches to 0xx numbers range to denote that this is backported code and they should be removed when we update kernel to version >= 3.19 Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> SVN-Revision: 44732
Diffstat (limited to 'target/linux/atheros/patches-3.18/101-early-printk-support.patch')
-rw-r--r--target/linux/atheros/patches-3.18/101-early-printk-support.patch68
1 files changed, 0 insertions, 68 deletions
diff --git a/target/linux/atheros/patches-3.18/101-early-printk-support.patch b/target/linux/atheros/patches-3.18/101-early-printk-support.patch
deleted file mode 100644
index bd937d34a6..0000000000
--- a/target/linux/atheros/patches-3.18/101-early-printk-support.patch
+++ /dev/null
@@ -1,68 +0,0 @@
---- /dev/null
-+++ b/arch/mips/ath25/early_printk.c
-@@ -0,0 +1,44 @@
-+/*
-+ * This file is subject to the terms and conditions of the GNU General Public
-+ * License. See the file "COPYING" in the main directory of this archive
-+ * for more details.
-+ *
-+ * Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
-+ */
-+
-+#include <linux/mm.h>
-+#include <linux/io.h>
-+#include <linux/serial_reg.h>
-+
-+#include "devices.h"
-+#include "ar2315_regs.h"
-+#include "ar5312_regs.h"
-+
-+static inline void prom_uart_wr(void __iomem *base, unsigned reg,
-+ unsigned char ch)
-+{
-+ __raw_writel(ch, base + 4 * reg);
-+}
-+
-+static inline unsigned char prom_uart_rr(void __iomem *base, unsigned reg)
-+{
-+ return __raw_readl(base + 4 * reg);
-+}
-+
-+void prom_putchar(unsigned char ch)
-+{
-+ static void __iomem *base;
-+
-+ if (unlikely(base == NULL)) {
-+ if (is_ar2315())
-+ base = (void __iomem *)(KSEG1ADDR(AR2315_UART0_BASE));
-+ else
-+ base = (void __iomem *)(KSEG1ADDR(AR5312_UART0_BASE));
-+ }
-+
-+ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
-+ ;
-+ prom_uart_wr(base, UART_TX, ch);
-+ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
-+ ;
-+}
---- a/arch/mips/ath25/Makefile
-+++ b/arch/mips/ath25/Makefile
-@@ -9,5 +9,8 @@
- #
-
- obj-y += board.o prom.o devices.o
-+
-+obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
-+
- obj-$(CONFIG_SOC_AR5312) += ar5312.o
- obj-$(CONFIG_SOC_AR2315) += ar2315.o
---- a/arch/mips/Kconfig
-+++ b/arch/mips/Kconfig
-@@ -106,6 +106,7 @@ config ATH25
- select SYS_HAS_CPU_MIPS32_R1
- select SYS_SUPPORTS_BIG_ENDIAN
- select SYS_SUPPORTS_32BIT_KERNEL
-+ select SYS_HAS_EARLY_PRINTK
- help
- Support for Atheros AR231x and Atheros AR531x based boards
-