aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-2.6.28/120-watchdog.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2009-02-20 16:27:42 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2009-02-20 16:27:42 +0000
commit668860c98f79e2b17febcaa1eb5c70aecdedbb9a (patch)
tree91616eac9f23649611a0ac944a33bbc63e9aa7dc /target/linux/atheros/patches-2.6.28/120-watchdog.patch
parentcde75fb5af88044e36cae6b24703eb51faca746b (diff)
downloadupstream-668860c98f79e2b17febcaa1eb5c70aecdedbb9a.tar.gz
upstream-668860c98f79e2b17febcaa1eb5c70aecdedbb9a.tar.bz2
upstream-668860c98f79e2b17febcaa1eb5c70aecdedbb9a.zip
Add initial kernel 2.6.28 support for atheros target. The include files moved from /include/asm-mips/mach-atheros/ to /arch/mips/include/asm/mach-atheros/ This patch is based on the old kernel 2.6.27 patches.
SVN-Revision: 14584
Diffstat (limited to 'target/linux/atheros/patches-2.6.28/120-watchdog.patch')
-rw-r--r--target/linux/atheros/patches-2.6.28/120-watchdog.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/atheros/patches-2.6.28/120-watchdog.patch b/target/linux/atheros/patches-2.6.28/120-watchdog.patch
new file mode 100644
index 0000000000..88c42a2a83
--- /dev/null
+++ b/target/linux/atheros/patches-2.6.28/120-watchdog.patch
@@ -0,0 +1,25 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -747,6 +747,12 @@ config TXX9_WDT
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config ATHEROS_WDT
++ tristate "Atheros wisoc Watchdog Timer"
++ depends on ATHEROS
++ help
++ Hardware driver for the Atheros wisoc Watchdog Timer.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -106,6 +106,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_ATHEROS_WDT) += ar2315-wtd.o
+
+ # PARISC Architecture
+