aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-2.6.27/130-ar2313_ethernet.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-10-09 08:08:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-10-09 08:08:13 +0000
commitefc3f8a1ef202b0ed250363696a12b24e9ccb361 (patch)
tree125dc029d228247a3dc84c04f882a3af7f1d05de /target/linux/atheros/patches-2.6.27/130-ar2313_ethernet.patch
parent1f819de60e94eab20a63012711e17116a2a9b2a0 (diff)
downloadupstream-efc3f8a1ef202b0ed250363696a12b24e9ccb361.tar.gz
upstream-efc3f8a1ef202b0ed250363696a12b24e9ccb361.tar.bz2
upstream-efc3f8a1ef202b0ed250363696a12b24e9ccb361.zip
experimental support for 2.6.27
SVN-Revision: 12932
Diffstat (limited to 'target/linux/atheros/patches-2.6.27/130-ar2313_ethernet.patch')
-rw-r--r--target/linux/atheros/patches-2.6.27/130-ar2313_ethernet.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/atheros/patches-2.6.27/130-ar2313_ethernet.patch b/target/linux/atheros/patches-2.6.27/130-ar2313_ethernet.patch
new file mode 100644
index 0000000000..c615a71b90
--- /dev/null
+++ b/target/linux/atheros/patches-2.6.27/130-ar2313_ethernet.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -359,6 +359,12 @@
+ help
+ Select this if your platform comes with an external 93CX6 eeprom.
+
++config AR2313
++ tristate "AR2313 Ethernet support"
++ depends on NET_ETHERNET && ATHEROS
++ help
++ Support for the AR231x/531x ethernet controller
++
+ config MACE
+ tristate "MACE (Power Mac ethernet) support"
+ depends on PPC_PMAC && PPC32
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -195,6 +195,7 @@
+ obj-$(CONFIG_KORINA) += korina.o
+ obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
+ obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
++obj-$(CONFIG_AR2313) += ar2313/
+ obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
+ obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
+ obj-$(CONFIG_DECLANCE) += declance.o