aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-2.6.27/110-spiflash.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-10-09 08:08:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-10-09 08:08:13 +0000
commitefc3f8a1ef202b0ed250363696a12b24e9ccb361 (patch)
tree125dc029d228247a3dc84c04f882a3af7f1d05de /target/linux/atheros/patches-2.6.27/110-spiflash.patch
parent1f819de60e94eab20a63012711e17116a2a9b2a0 (diff)
downloadupstream-efc3f8a1ef202b0ed250363696a12b24e9ccb361.tar.gz
upstream-efc3f8a1ef202b0ed250363696a12b24e9ccb361.tar.bz2
upstream-efc3f8a1ef202b0ed250363696a12b24e9ccb361.zip
experimental support for 2.6.27
SVN-Revision: 12932
Diffstat (limited to 'target/linux/atheros/patches-2.6.27/110-spiflash.patch')
-rw-r--r--target/linux/atheros/patches-2.6.27/110-spiflash.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/atheros/patches-2.6.27/110-spiflash.patch b/target/linux/atheros/patches-2.6.27/110-spiflash.patch
new file mode 100644
index 0000000000..e8dbc7a052
--- /dev/null
+++ b/target/linux/atheros/patches-2.6.27/110-spiflash.patch
@@ -0,0 +1,20 @@
+--- a/drivers/mtd/devices/Kconfig
++++ b/drivers/mtd/devices/Kconfig
+@@ -83,6 +83,10 @@
+ help
+ This option enables FAST_READ access supported by ST M25Pxx.
+
++config MTD_SPIFLASH
++ tristate "Atheros AR2315/6/7 SPI Flash support"
++ depends on ATHEROS_AR5315
++
+ config MTD_SLRAM
+ tristate "Uncached system RAM"
+ help
+--- a/drivers/mtd/devices/Makefile
++++ b/drivers/mtd/devices/Makefile
+@@ -16,3 +16,4 @@
+ obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd.o
+ obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
+ obj-$(CONFIG_MTD_M25P80) += m25p80.o
++obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o