aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-12-18 13:31:59 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-12-18 13:31:59 +0000
commitc2c9472aa6b1d1f57356af22648078ce5581452b (patch)
tree3340c9fd0e3be3974200bef25003ab182b951bc4 /target/linux/atheros/image
parent8e5e72994fbf3bf89eb83550dd4af7018aa7b419 (diff)
downloadupstream-c2c9472aa6b1d1f57356af22648078ce5581452b.tar.gz
upstream-c2c9472aa6b1d1f57356af22648078ce5581452b.tar.bz2
upstream-c2c9472aa6b1d1f57356af22648078ce5581452b.zip
[tools] firmware-utils/mkfwimage: add RouterStation support (based on a patch by Jonas <jonas at ubnt.com>)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13682 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros/image')
-rw-r--r--target/linux/atheros/image/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index 6df21c773e..4340e769df 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -23,20 +23,23 @@ define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
- -$(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B XS2 -v XS2.ar2316.OpenWrt \
+ -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma
-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
- -v XS2.ar2316.OpenWRT \
-o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-$(1).bin
- -$(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B XS5 -v XS5.ar2313.OpenWrt \
+ -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
- -v XS5.ar2313.OpenWRT \
- -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin \
- -s 0xBE030000
+ -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin
-$(STAGING_DIR_HOST)/bin/mkmylofw -B np25g \
-p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz \
-p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
$(BIN_DIR)/openwrt-$(BOARD)-np25g-$(1).bin
+
-$(STAGING_DIR_HOST)/bin/mkmylofw -B wpe53g \
-p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz \
-p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \