aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/image
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-09-22 01:09:04 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-09-22 01:09:04 +0000
commit92bc60d8f37f14ef4285b23141033bdb5cf57c94 (patch)
treefd68a9d1f91c5113d92b9731edff5bf7bb6adb28 /target/linux/atheros/image
parent2e50e61cf210177b7fd4cfcac9dbad39229c1759 (diff)
downloadupstream-92bc60d8f37f14ef4285b23141033bdb5cf57c94.tar.gz
upstream-92bc60d8f37f14ef4285b23141033bdb5cf57c94.tar.bz2
upstream-92bc60d8f37f14ef4285b23141033bdb5cf57c94.zip
[atheros] Implement a preliminary combined image format.
- add sysupgrade support for combined images by providing a platform.sh backend - use the mtd fis partition table rewrite facility to resize partitions on demand - generate generic combined images for the atheros target git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17668 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros/image')
-rw-r--r--target/linux/atheros/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index 40044895b8..15cd995865 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -51,6 +51,12 @@ define Image/Build
-p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
$(BIN_DIR)/openwrt-$(BOARD)-wpe53g-$(1).bin
+ ifeq ($(BOARD),atheros)
+ -sh $(TOPDIR)/scripts/combined-image.sh \
+ "$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma" \
+ "$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" \
+ "$(BIN_DIR)/openwrt-$(BOARD)-combined.img"
+ endif
endef
$(eval $(call BuildImage))