aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/image
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-21 01:16:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-21 01:16:34 +0000
commit3c7b1324a5f77c0bede093dc9c8b5de9c270dc58 (patch)
treea2266dafcd85ed6d2a125fe438eacc35d0c25380 /target/linux/atheros/image
parent902e698c9901f8480b1eecb31b92cdf9228e0c5d (diff)
downloadupstream-3c7b1324a5f77c0bede093dc9c8b5de9c270dc58.tar.gz
upstream-3c7b1324a5f77c0bede093dc9c8b5de9c270dc58.tar.bz2
upstream-3c7b1324a5f77c0bede093dc9c8b5de9c270dc58.zip
[atheros] Generate suitable images for the UBNT PicoStation2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15314 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros/image')
-rw-r--r--target/linux/atheros/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index 73657334ee..e2f6315705 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -35,6 +35,12 @@ define Image/Build
-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
-o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B XS2-8 -v XS2.ar2316.OpenWrt.$(REVISION) \
+ -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+ -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+ -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-8-$(1).bin
+
-$(STAGING_DIR_HOST)/bin/mkmylofw -B np25g \
-p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz \
-p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \