aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros-2.6/patches/110-spiflash.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-07-12 10:19:36 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-07-12 10:19:36 +0000
commit9dc0ee886a85be424780a3b7a98b76a0bbc389a1 (patch)
tree6fecbede6915caf176d680eda96898447e32a3ef /target/linux/atheros-2.6/patches/110-spiflash.patch
parentbe2a8e9b2516721dcb4abbb2f460ddbe55d527c8 (diff)
downloadupstream-9dc0ee886a85be424780a3b7a98b76a0bbc389a1.tar.gz
upstream-9dc0ee886a85be424780a3b7a98b76a0bbc389a1.tar.bz2
upstream-9dc0ee886a85be424780a3b7a98b76a0bbc389a1.zip
upgrade atheros targets to 2.6.22.1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7936 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros-2.6/patches/110-spiflash.patch')
-rw-r--r--target/linux/atheros-2.6/patches/110-spiflash.patch11
1 files changed, 5 insertions, 6 deletions
diff --git a/target/linux/atheros-2.6/patches/110-spiflash.patch b/target/linux/atheros-2.6/patches/110-spiflash.patch
index e6461ff06d..fc4ef4c0f2 100644
--- a/target/linux/atheros-2.6/patches/110-spiflash.patch
+++ b/target/linux/atheros-2.6/patches/110-spiflash.patch
@@ -1,23 +1,22 @@
diff -urN linux.old/drivers/mtd/devices/Kconfig linux.dev/drivers/mtd/devices/Kconfig
--- linux.old/drivers/mtd/devices/Kconfig 2007-02-04 04:30:26.145338240 +0100
+++ linux.dev/drivers/mtd/devices/Kconfig 2007-02-02 23:48:28.748969000 +0100
-@@ -68,6 +68,10 @@
+@@ -76,6 +76,10 @@
used for program and data storage. Set up your spi devices
with the right board-specific platform data.
+config MTD_SPIFLASH
+ tristate "Atheros AR2315/6/7 SPI Flash support"
-+ depends on MTD && ATHEROS_AR5315
++ depends on ATHEROS_AR5315
+
config MTD_SLRAM
tristate "Uncached system RAM"
- depends on MTD
+ help
diff -urN linux.old/drivers/mtd/devices/Makefile linux.dev/drivers/mtd/devices/Makefile
--- linux.old/drivers/mtd/devices/Makefile 2007-02-04 04:30:26.146338088 +0100
+++ linux.dev/drivers/mtd/devices/Makefile 2007-02-02 23:48:28.749969000 +0100
-@@ -17,3 +17,4 @@
- obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd.o
+@@ -18,3 +18,4 @@
obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
+ obj-$(CONFIG_MTD_DATAFLASH26) += at91_dataflash26.o
obj-$(CONFIG_MTD_M25P80) += m25p80.o
+obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o
-