aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-25 08:05:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-25 08:05:48 +0000
commit216e8fcc55397c76a8bf1f1fe55432921be77519 (patch)
tree0c99516845c66eab0c1fd0d5157d54525a659d91 /target/linux/atheros-2.6/image/Makefile
parentc4b3b0d9db7582b29290537bba4e6ecd64ec9ecb (diff)
downloadupstream-216e8fcc55397c76a8bf1f1fe55432921be77519.tar.gz
upstream-216e8fcc55397c76a8bf1f1fe55432921be77519.tar.bz2
upstream-216e8fcc55397c76a8bf1f1fe55432921be77519.zip
Add support for Atheros SoC (used in Fonera, Meraki) - Merry Christmas, everybody :)
SVN-Revision: 5898
Diffstat (limited to 'target/linux/atheros-2.6/image/Makefile')
-rw-r--r--target/linux/atheros-2.6/image/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/atheros-2.6/image/Makefile b/target/linux/atheros-2.6/image/Makefile
new file mode 100644
index 0000000000..fb8cf3ced2
--- /dev/null
+++ b/target/linux/atheros-2.6/image/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(KDIR)/linux-*/vmlinux $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+ gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
+ $(STAGING_DIR)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
+ dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.lzma bs=65536 conv=sync
+ dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.gz bs=65536 conv=sync
+endef
+
+define Image/Build
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-root.$(1) bs=128k conv=sync
+endef
+
+
+$(eval $(call BuildImage))