aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-02 01:38:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-02 01:38:07 +0000
commit384e5dde8beede5fc4ac76d54f4676ce4a4601fb (patch)
treee80f8065408ab81f2d62430c7f4da2688092eb1c /target/linux/atheros-2.6/image/Makefile
parent18de319d9d7693da2798604e676e3eff0094bde1 (diff)
downloadupstream-384e5dde8beede5fc4ac76d54f4676ce4a4601fb.tar.gz
upstream-384e5dde8beede5fc4ac76d54f4676ce4a4601fb.tar.bz2
upstream-384e5dde8beede5fc4ac76d54f4676ce4a4601fb.zip
add squashfs support for atheros-2.6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6451 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros-2.6/image/Makefile')
-rw-r--r--target/linux/atheros-2.6/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/atheros-2.6/image/Makefile b/target/linux/atheros-2.6/image/Makefile
index 80e3335920..dfd1746fd3 100644
--- a/target/linux/atheros-2.6/image/Makefile
+++ b/target/linux/atheros-2.6/image/Makefile
@@ -19,7 +19,12 @@ define Image/BuildKernel
dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.gz bs=65536 conv=sync
endef
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
define Image/Build
+ $(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-root.$(1) bs=128k conv=sync
endef