aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2023-01-13 03:17:54 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-23 18:57:29 +0200
commitf3bb1eea32c728470563e7e0df8bd905a913e074 (patch)
treed5814abf42493def0696dfdb70b41ee4ed93edb3 /target/linux/ath79
parent304423a4ff841129f1b6b7504c83dd11c1f71c84 (diff)
downloadupstream-f3bb1eea32c728470563e7e0df8bd905a913e074.tar.gz
upstream-f3bb1eea32c728470563e7e0df8bd905a913e074.tar.bz2
upstream-f3bb1eea32c728470563e7e0df8bd905a913e074.zip
ath79: fix switch support for WZR-HP-G300NH devices
Switch drivers for RTL8366S/RB were packaged as modules but not properly added to device definitions for WZR-HP-G300NH router variants, breaking network access to both after installation or upgrade. Assign the correct switch driver package for each router. Fixes: 6e0f0eae5b ("ath79: use rtl8366s and rtl8366_smi as a module") Fixes: 575ec7a4b1 ("ath79: use rtl8366rb as a module") Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/image/generic.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 68ecba972b..dda74f04f4 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -611,13 +611,14 @@ endef
define Device/buffalo_wzr-hp-g300nh-rb
$(Device/buffalo_wzr-hp-g300nh)
DEVICE_MODEL := WZR-HP-G300NH (RTL8366RB switch)
+ DEVICE_PACKAGES += kmod-switch-rtl8366rb
endef
TARGET_DEVICES += buffalo_wzr-hp-g300nh-rb
define Device/buffalo_wzr-hp-g300nh-s
$(Device/buffalo_wzr-hp-g300nh)
DEVICE_MODEL := WZR-HP-G300NH (RTL8366S switch)
- DEVICE_PACKAGES += kmod-switch-rtl8366rb
+ DEVICE_PACKAGES += kmod-switch-rtl8366s
endef
TARGET_DEVICES += buffalo_wzr-hp-g300nh-s