aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-12-09 15:45:04 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-06 15:34:07 +0100
commit8342c092a03caedbf160d4ac3982c6a9be91261f (patch)
tree8572a76972b8e5ce1365f0faabeb73cc9dafbe32 /target/linux/ath79
parent169878a190c2d42ffb5f6d10017e627da852e467 (diff)
downloadupstream-8342c092a03caedbf160d4ac3982c6a9be91261f.tar.gz
upstream-8342c092a03caedbf160d4ac3982c6a9be91261f.tar.bz2
upstream-8342c092a03caedbf160d4ac3982c6a9be91261f.zip
ath79: use lzma-loader for Senao initramfs images
Some vendors of Senao boards have put a bootloader that cannot handle both large gzip or large lzma files. There is no disadvantage by doing this for all of them. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/image/common-senao.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ath79/image/common-senao.mk b/target/linux/ath79/image/common-senao.mk
index e0e60dbe27..9034aa28db 100644
--- a/target/linux/ath79/image/common-senao.mk
+++ b/target/linux/ath79/image/common-senao.mk
@@ -37,6 +37,7 @@ endef
define Device/senao_loader_okli
$(Device/loader-okli-uimage)
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x73714f4b
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel | uImage none
LOADER_KERNEL_MAGIC := 0x73714f4b
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \