aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2022-12-03 15:25:12 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-12-19 12:27:35 +0000
commit17c6fb1054e3dde8fa573195acaac42a5edf0942 (patch)
tree67daee958663691420b4f941c9343ca7e03551cb /target/linux/ath79
parent1bff0752bd5e7feb0f311224a09b3bf217a9aeb3 (diff)
downloadupstream-17c6fb1054e3dde8fa573195acaac42a5edf0942.tar.gz
upstream-17c6fb1054e3dde8fa573195acaac42a5edf0942.tar.bz2
upstream-17c6fb1054e3dde8fa573195acaac42a5edf0942.zip
ath79: image: don't depend on other COMPILE targets
A device COMPILE target should not depend on another COMPILE. Otherwise race condition may happen. The loader is very small. Compiling it twice shouldn't have a huge impact. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 712ab941e1..8328be7667 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -83,7 +83,7 @@ define Device/loader-okli-uimage
LOADER_TYPE := bin
COMPILE := loader-$(1).bin loader-$(1).uImage
COMPILE/loader-$(1).bin := loader-okli-compile
- COMPILE/loader-$(1).uImage := append-loader-okli $(1) | pad-to 64k | \
+ COMPILE/loader-$(1).uImage := loader-okli-compile | pad-to 64k | \
lzma | uImage lzma
endef