aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2022-01-13 22:08:38 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-01-16 21:42:19 +0100
commitebf639d282ca035c4ac5220371595905eff61eee (patch)
tree94de9bfceb69b90bbef25bf97e59a3a29b924f82 /target/linux/ath79
parent8143709c90c3aa0a84e14cf4a9dfbcb365b0d966 (diff)
downloadupstream-ebf639d282ca035c4ac5220371595905eff61eee.tar.gz
upstream-ebf639d282ca035c4ac5220371595905eff61eee.tar.bz2
upstream-ebf639d282ca035c4ac5220371595905eff61eee.zip
ath79: use lzma-loader for ZyXEL NBG6716
Since gzip-compressed kernel image stopped fitting on 4MB kernel partition on the device, use lzma-loader wrapping LZMA-compressed kernel. This yields bootable device once again, and saves a very substantial amount of space, the kernel size decreasing from about 4.4MB to about 2.5MB for 5.10 kernel. This avoids changing of the flash layout for the device. While at that, reactivate the build for the device. Fixes: 5d8ea6d34f9 ("ath79: Deactivate ZyXEL NBG6716 by default") Cc: André Valentin <avalentin@marcant.net> Cc: Hauke Mehrtens <hauke@hauke-m.de> Tested-by: Alex Henrie <alexhenrie24@gmail.com> Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/image/nand.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 91fd7ec301..d31aba1abc 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -301,8 +301,9 @@ define Device/zyxel_nbg6716
KERNEL_SIZE := 4096k
BLOCKSIZE := 128k
PAGESIZE := 2048
- KERNEL := kernel-bin | append-dtb | uImage none | zyxel-buildkerneljffs | \
- check-size 4096k
+ LOADER_TYPE := bin
+ KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | uImage none | \
+ zyxel-buildkerneljffs | check-size 4096k
IMAGES := sysupgrade.tar sysupgrade-4M-Kernel.bin factory.bin
IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-to $$$$(BLOCKSIZE) | \
sysupgrade-tar rootfs=$$$$@ | append-metadata
@@ -311,6 +312,5 @@ define Device/zyxel_nbg6716
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
zyxel-factory
UBINIZE_OPTS := -E 5
- DEFAULT := n
endef
TARGET_DEVICES += zyxel_nbg6716