aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorWenli Looi <wlooi@ucalgary.ca>2021-06-12 16:32:33 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2022-02-07 00:03:27 +0100
commitc32008a37b81d0ab1062993241a1e9f0a8e73102 (patch)
treebde00c3a371be4fb24cd10a19202cfc3f4d64a05 /target/linux/ath79
parent6ede645282f94c32a33a2c6858375b8c2f609922 (diff)
downloadupstream-c32008a37b81d0ab1062993241a1e9f0a8e73102.tar.gz
upstream-c32008a37b81d0ab1062993241a1e9f0a8e73102.tar.bz2
upstream-c32008a37b81d0ab1062993241a1e9f0a8e73102.zip
ath79: add partial support for Netgear EX7300v2
Hardware -------- SoC: QCN5502 Flash: 16 MiB RAM: 128 MiB Ethernet: 1 gigabit port Wireless No1: QCN5502 on-chip 2.4GHz 4x4 Wireless No2: QCA9984 pcie 5GHz 4x4 USB: none Installation ------------ Flash the factory image using the stock web interface or TFTP the factory image to the bootloader. What works ---------- - LEDs - Ethernet port - 5GHz wifi (QCA9984 pcie) What doesn't work ----------------- - 2.4GHz wifi (QCN5502 on-chip) (I was not able to make this work, probably because ath9k requires some changes to support QCN5502.) Signed-off-by: Wenli Looi <wlooi@ucalgary.ca>
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/dts/qcn5502_netgear_ex7300-v2.dts219
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata4
-rw-r--r--target/linux/ath79/image/generic.mk17
4 files changed, 241 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/qcn5502_netgear_ex7300-v2.dts b/target/linux/ath79/dts/qcn5502_netgear_ex7300-v2.dts
new file mode 100644
index 0000000000..ba8dae0b36
--- /dev/null
+++ b/target/linux/ath79/dts/qcn5502_netgear_ex7300-v2.dts
@@ -0,0 +1,219 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca956x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ model = "Netgear EX7300 v2";
+ compatible = "netgear,ex7300-v2", "qca,qcn5500", "qca,qca9560";
+
+ aliases {
+ led-boot = &led_power_green;
+ led-failsafe = &led_power_amber;
+ led-running = &led_power_green;
+ led-upgrade = &led_power_amber;
+ label-mac-device = &eth0;
+ };
+
+ led_spi {
+ compatible = "spi-gpio";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ sck-gpios = <&gpio 14 GPIO_ACTIVE_HIGH>;
+ mosi-gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+ num-chipselects = <0>;
+
+ led_gpio: led_gpio@0 {
+ compatible = "fairchild,74hc595";
+ reg = <0>;
+ gpio-controller;
+ #gpio-cells = <2>;
+ registers-number = <1>;
+ spi-max-frequency = <500000>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power_green: power_green {
+ label = "green:power";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ };
+
+ led_power_amber: power_amber {
+ label = "amber:power";
+ gpios = <&led_gpio 7 GPIO_ACTIVE_LOW>;
+ };
+
+ wps_green {
+ label = "green:wps";
+ gpios = <&led_gpio 6 GPIO_ACTIVE_LOW>;
+ };
+
+ router_red {
+ label = "red:router";
+ gpios = <&led_gpio 5 GPIO_ACTIVE_LOW>;
+ };
+
+ router_green {
+ label = "green:router";
+ gpios = <&led_gpio 4 GPIO_ACTIVE_LOW>;
+ };
+
+ client_red {
+ label = "red:client";
+ gpios = <&led_gpio 3 GPIO_ACTIVE_LOW>;
+ };
+
+ client_green {
+ label = "green:client";
+ gpios = <&led_gpio 2 GPIO_ACTIVE_LOW>;
+ };
+
+ left_blue {
+ label = "blue:left";
+ gpios = <&led_gpio 1 GPIO_ACTIVE_LOW>;
+ };
+
+ right_blue {
+ label = "blue:right";
+ gpios = <&led_gpio 0 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "Reset button";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ wps {
+ label = "WPS button";
+ linux,code = <KEY_WPS_BUTTON>;
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ extender_apmode {
+ label = "EXTENDER/APMODE switch";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_0>;
+ linux,input-type = <EV_SW>;
+ debounce-interval = <60>;
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pll {
+ clocks = <&extosc>;
+};
+
+&spi {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x040000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "u-boot-env";
+ reg = <0x040000 0x010000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "config";
+ reg = <0x050000 0x010000>;
+ };
+
+ partition@60000 {
+ label = "pot";
+ reg = <0x060000 0x010000>;
+ read-only;
+ };
+
+ partition@70000 {
+ label = "firmware";
+ reg = <0x70000 0xe30000>;
+ compatible = "denx,uimage";
+ };
+
+ partition@ea0000 {
+ label = "rae";
+ reg = <0xea0000 0x100000>;
+ read-only;
+ };
+
+ partition@fa0000 {
+ label = "oopsdump";
+ reg = <0xfa0000 0x40000>;
+ read-only;
+ };
+
+ artmtd: partition@fe0000 {
+ label = "artmtd";
+ reg = <0xfe0000 0x10000>;
+ };
+
+ art: partition@ff0000 {
+ label = "art";
+ reg = <0xff0000 0x10000>;
+ read-only;
+ };
+ };
+ };
+};
+
+/*
+Does not work due to lack of QCN5502 support in ath9k.
+&wmac {
+ status = "okay";
+
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&artmtd 0x6>;
+};
+*/
+
+&mdio0 {
+ status = "okay";
+
+ phy5: ethernet-phy@5 {
+ reg = <5>;
+ phy-mode = "sgmii";
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ mtd-mac-address = <&artmtd 0x0>;
+
+ phy-handle = <&phy5>;
+ phy-mode = "sgmii";
+
+ pll-data = <0x03000000 0x00000101 0x00001313>;
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 83e74f0651..b80f8cd266 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -44,6 +44,7 @@ ath79_setup_interfaces()
meraki,mr16|\
netgear,ex6400|\
netgear,ex7300|\
+ netgear,ex7300-v2|\
ocedo,koala|\
ocedo,raccoon|\
onion,omega|\
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 109b33795a..787d56c237 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -218,6 +218,10 @@ case "$FIRMWARE" in
caldata_extract "caldata" 0x5000 0x2f20
ath10k_patch_mac $(mtd_get_mac_binary caldata 0xc)
;;
+ netgear,ex7300-v2)
+ caldata_extract "art" 0x5000 0x2f20
+ ath10k_patch_mac $(mtd_get_mac_binary artmtd 0xc)
+ ;;
phicomm,k2t)
caldata_extract "art" 0x5000 0x2f20
ath10k_patch_mac $(k2t_get_mac "5g_mac")
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b3598a2000..3b23267b70 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1580,6 +1580,23 @@ define Device/netgear_ex7300
endef
TARGET_DEVICES += netgear_ex7300
+define Device/netgear_ex7300-v2
+ $(Device/netgear_generic)
+ SOC := qcn5502
+ DEVICE_MODEL := EX7300
+ DEVICE_VARIANT := v2
+ UIMAGE_MAGIC := 0x27051956
+ NETGEAR_BOARD_ID := EX7300v2series
+ NETGEAR_HW_ID := 29765907+16+0+128
+ IMAGE_SIZE := 14528k
+ IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
+ netgear-rootfs | pad-rootfs
+ IMAGE/sysupgrade.bin := $$(IMAGE/default) | check-size | append-metadata
+ IMAGE/factory.img := $$(IMAGE/default) | check-size | netgear-dni
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9984-ct
+endef
+TARGET_DEVICES += netgear_ex7300-v2
+
define Device/netgear_wndr3x00
$(Device/netgear_generic)
SOC := ar7161