aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorDaniel González Cabanelas <dgcbueu@gmail.com>2022-01-16 19:00:19 +0100
committerPetr Štetiar <ynezz@true.cz>2022-02-19 13:10:01 +0100
commit73ea763c0dcdb96c9163790f20edd964399035c0 (patch)
tree2080eec504e24e018d7c7de80f8f181ba9874210 /target/linux/ath79
parent66071729a27919e555752fce25210b1b035eb319 (diff)
downloadupstream-73ea763c0dcdb96c9163790f20edd964399035c0.tar.gz
upstream-73ea763c0dcdb96c9163790f20edd964399035c0.tar.bz2
upstream-73ea763c0dcdb96c9163790f20edd964399035c0.zip
ath79: Add support for Ubiquiti NanoBeam AC Gen1 XC
The Ubiquiti NanoBeam AC Gen1 XC (NBE-5AC-19) is an outdoor 802.11ac CPE with a waterproof casing (ultrasonically welded) and bulb shaped. Hardware: - SoC: Qualcomm Atheros QCA9558 - RAM: 128 MB DDR2 - Flash: 16 MB SPI NOR - Ethernet: 1x GbE, AR8033 phy connected via SGMII - PSU: 24 Vdc passive PoE - WiFi 5 GHz: Qualcomm Atheros QCA988X - Buttons: 1x reset - LEDs: 1x power, 1x Ethernet, 4x RSSI, all blue - Internal antenna: 19 dBi planar Installation from stock airOS firmware: - Follow instructions for XC-type Ubiquiti devices on OpenWrt wiki at https://openwrt.org/toh/ubiquiti/common Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/dts/qca9558_ubnt_nanobeam-ac-xc.dts111
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/01_leds1
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata1
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk9
5 files changed, 124 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/qca9558_ubnt_nanobeam-ac-xc.dts b/target/linux/ath79/dts/qca9558_ubnt_nanobeam-ac-xc.dts
new file mode 100644
index 0000000000..14388079b6
--- /dev/null
+++ b/target/linux/ath79/dts/qca9558_ubnt_nanobeam-ac-xc.dts
@@ -0,0 +1,111 @@
+// SPDX-License-Identifier: GPL-2.0-only
+/*
+ * Device Tree file for Ubiquiti Nanobeam NBE-5AC-19 (XC)
+ *
+ * Copyright (C) 2022 Daniel González Cabanelas <dgcbueu@gmail.com>
+ * based on device tree from qca9558_ubnt_powerbeam-5ac-500.dts
+ */
+
+#include "qca955x_ubnt_xc.dtsi"
+
+/ {
+ compatible = "ubnt,nanobeam-ac-xc", "ubnt,xc", "qca,qca9558";
+ model = "Ubiquiti NanoBeam AC Gen1 (XC)";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "Reset button";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ led_spi {
+ compatible = "spi-gpio";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ sck-gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+ mosi-gpios = <&gpio 1 GPIO_ACTIVE_HIGH>;
+ cs-gpios = <&gpio 3 GPIO_ACTIVE_HIGH>;
+ num-chipselects = <1>;
+
+ led_gpio: led_gpio@0 {
+ compatible = "fairchild,74hc595";
+ reg = <0>;
+ gpio-controller;
+ #gpio-cells = <2>;
+ registers-number = <1>;
+ spi-max-frequency = <10000000>;
+ enable-gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ rssi0 {
+ label = "blue:rssi0";
+ gpios = <&led_gpio 0 GPIO_ACTIVE_LOW>;
+ };
+ rssi1 {
+ label = "blue:rssi1";
+ gpios = <&led_gpio 1 GPIO_ACTIVE_LOW>;
+ };
+ rssi2 {
+ label = "blue:rssi2";
+ gpios = <&led_gpio 2 GPIO_ACTIVE_LOW>;
+ };
+ rssi3 {
+ label = "blue:rssi3";
+ gpios = <&led_gpio 3 GPIO_ACTIVE_LOW>;
+ };
+ led_power: power {
+ label = "blue:power";
+ gpios = <&led_gpio 4 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+ };
+};
+
+&mdio0 {
+ status = "okay";
+
+ phy-mask = <4>;
+ phy4: ethernet-phy@4 {
+ phy-mode = "sgmii";
+ reg = <4>;
+ at803x-override-sgmii-link-check;
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ pll-reg = <0 0x48 0>;
+ pll-data = <0x03000000 0x00000101 0x00001313>;
+ nvmem-cells = <&macaddr_art_0>;
+ nvmem-cell-names = "mac-address";
+ phy-mode = "sgmii";
+ phy-handle = <&phy4>;
+};
+
+&art {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_art_0: macaddr@0 {
+ reg = <0x0 0x6>;
+ };
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index c8717ce0cc..18904f8528 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -414,6 +414,7 @@ trendnet,tew-823dru)
ubnt,bullet-ac|\
ubnt,nanobeam-ac|\
ubnt,nanobeam-ac-gen2|\
+ubnt,nanobeam-ac-xc|\
ubnt,nanostation-ac|\
ubnt,powerbeam-5ac-gen2)
ucidef_set_rssimon "wlan0" "200000" "1"
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index b80f8cd266..447d1cdea2 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -85,6 +85,7 @@ ath79_setup_interfaces()
ubnt,lap-120|\
ubnt,litebeam-ac-gen2|\
ubnt,nanobeam-ac|\
+ ubnt,nanobeam-ac-xc|\
ubnt,nanobridge-m|\
ubnt,nanostation-ac-loco|\
ubnt,nanostation-loco-m|\
@@ -714,6 +715,7 @@ ath79_setup_macs()
;;
ubnt,litebeam-ac-gen2|\
ubnt,nanobeam-ac-gen2|\
+ ubnt,nanobeam-ac-xc|\
ubnt,powerbeam-5ac-500|\
ubnt,powerbeam-5ac-gen2)
label_mac=$(mtd_get_mac_binary art 0x5006)
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 787d56c237..cf16fa2318 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -37,6 +37,7 @@ case "$FIRMWARE" in
ubnt,litebeam-ac-gen2|\
ubnt,nanobeam-ac|\
ubnt,nanobeam-ac-gen2|\
+ ubnt,nanobeam-ac-xc|\
ubnt,nanostation-ac|\
ubnt,nanostation-ac-loco|\
ubnt,powerbeam-5ac-500|\
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index bb5eaa5458..9470adf48b 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -246,6 +246,15 @@ define Device/ubnt_nanobeam-ac-gen2
endef
TARGET_DEVICES += ubnt_nanobeam-ac-gen2
+define Device/ubnt_nanobeam-ac-xc
+ $(Device/ubnt-xc)
+ SOC := qca9558
+ DEVICE_MODEL := NanoBeam AC
+ DEVICE_VARIANT := Gen1 (XC)
+ DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct rssileds
+endef
+TARGET_DEVICES += ubnt_nanobeam-ac-xc
+
define Device/ubnt_nanobridge-m
$(Device/ubnt-xm)
SOC := ar7241