aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2022-02-17 23:22:25 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2022-02-27 16:54:54 +0100
commit131671bc54dff89c33c10241b8fca8fa34a9b2bf (patch)
tree1ede76b4dfe411e27a4fb2e9b253248bb582eb52 /target/linux/ath79
parent53ac6ee552baca52f3f18fc95b793c03e1bf9581 (diff)
downloadupstream-131671bc54dff89c33c10241b8fca8fa34a9b2bf.tar.gz
upstream-131671bc54dff89c33c10241b8fca8fa34a9b2bf.tar.bz2
upstream-131671bc54dff89c33c10241b8fca8fa34a9b2bf.zip
ath79: add support for ALFA Network Tube-2HQ
ALFA Network Tube-2HQ is a successor of the Tube-2H/P series (EOL) which was based on the Atheros AR9331. The new version uses Qualcomm QCA9531. Specifications: - Qualcomm/Atheros QCA9531 v2 - 650/400/200 MHz (CPU/DDR/AHB) - 64 or 128 MB of RAM (DDR2) - 16+ MB of flash (SPI NOR) - 1x 10/100 Mbps Ethernet with passive PoE input (24 V) (802.3at/af PoE support with optional module) - 1T1R 2.4 GHz Wi-Fi with external PA (SE2623L, up to 27 dBm) and LNA - 1x Type-N (male) antenna connector - 6x LED (5x driven by GPIO) - 1x button (reset) - external h/w watchdog (EM6324QYSP5B, enabled by default) - UART (4-pin, 2.00 mm pitch) header on PCB Flash instruction: You can use sysupgrade image directly in vendor firmware which is based on LEDE/OpenWrt. Alternatively, you can use web recovery mode in U-Boot: 1. Configure PC with static IP 192.168.1.2/24. 2. Connect PC with one of RJ45 ports, press the reset button, power up device, wait for first blink of all LEDs (indicates network setup), then keep button for 3 following blinks and release it. 3. Open 192.168.1.1 address in your browser and upload sysupgrade image. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/dts/qca9531_alfa-network_tube-2hq.dts65
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/01_leds8
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/ath79/image/generic.mk10
4 files changed, 85 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/qca9531_alfa-network_tube-2hq.dts b/target/linux/ath79/dts/qca9531_alfa-network_tube-2hq.dts
new file mode 100644
index 0000000000..f81fe287df
--- /dev/null
+++ b/target/linux/ath79/dts/qca9531_alfa-network_tube-2hq.dts
@@ -0,0 +1,65 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9531_alfa-network_r36a.dtsi"
+
+/ {
+ model = "ALFA Network Tube-2HQ";
+ compatible = "alfa-network,tube-2hq", "qca,qca9531";
+
+ aliases {
+ led-boot = &led_signal4;
+ led-failsafe = &led_signal4;
+ led-upgrade = &led_signal4;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&enable_gpio4 &enable_gpio16>;
+
+ lan {
+ label = "blue:lan";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ };
+
+ led_signal4: signal4 {
+ label = "green:signal4";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ };
+
+ signal1 {
+ label = "red:signal1";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ };
+
+ signal2 {
+ label = "orange:signal2";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ };
+
+ signal3 {
+ label = "green:signal3";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&eth0 {
+ nvmem-cells = <&macaddr_art_1002>;
+ nvmem-cell-names = "mac-address";
+
+ mac-address-increment = <(-1)>;
+};
+
+&eth1 {
+ compatible = "syscon", "simple-mfd";
+};
+
+&usb0 {
+ status = "disabled";
+};
+
+&usb_phy {
+ status = "disabled";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 18904f8528..354df1da6f 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -48,6 +48,14 @@ alfa-network,r36a)
ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
ucidef_set_led_switch "wan" "WAN" "blue:wan" "switch0" "0x10"
;;
+alfa-network,tube-2hq)
+ ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
+ ucidef_set_rssimon "wlan0" "200000" "1"
+ ucidef_set_led_rssi "signal1" "SIGNAL1" "red:signal1" "wlan0" "1" "100"
+ ucidef_set_led_rssi "signal2" "SIGNAL2" "orange:signal2" "wlan0" "25" "100"
+ ucidef_set_led_rssi "signal3" "SIGNAL3" "green:signal3" "wlan0" "50" "100"
+ ucidef_set_led_rssi "signal4" "SIGNAL4" "green:signal4" "wlan0" "75" "100"
+ ;;
asus,rp-ac66)
ucidef_set_rssimon "wlan0" "200000" "1"
ucidef_set_rssimon "wlan1" "200000" "1"
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 447d1cdea2..bb5c63a33e 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -13,6 +13,7 @@ ath79_setup_interfaces()
allnet,all-wap02860ac|\
alfa-network,ap121f|\
alfa-network,pi-wifi4|\
+ alfa-network,tube-2hq|\
arduino,yun|\
aruba,ap-105|\
asus,rp-ac66|\
@@ -529,6 +530,7 @@ ath79_setup_macs()
alfa-network,n5q|\
alfa-network,pi-wifi4|\
alfa-network,r36a|\
+ alfa-network,tube-2hq|\
engenius,eap300-v2|\
engenius,ens202ext-v1)
label_mac=$(mtd_get_mac_binary art 0x1002)
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b01eff7d0b..27a9860d28 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -298,6 +298,16 @@ define Device/alfa-network_r36a
endef
TARGET_DEVICES += alfa-network_r36a
+define Device/alfa-network_tube-2hq
+ SOC := qca9531
+ DEVICE_VENDOR := ALFA Network
+ DEVICE_MODEL := Tube-2HQ
+ DEVICE_PACKAGES := rssileds -swconfig
+ IMAGE_SIZE := 15872k
+ SUPPORTED_DEVICES += tube-2hq
+endef
+TARGET_DEVICES += alfa-network_tube-2hq
+
define Device/allnet_all-wap02860ac
$(Device/senao_loader_okli)
SOC := qca9558