aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-07-27 12:30:41 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-20 14:19:39 +0200
commita14f5bb4bd263c21e103f13279d0c2ff03e48fe5 (patch)
tree18eecef0be1356f014d81b0427471ae18c8839c2 /target/linux/ath79
parentcc75344044e5c16cd4994d824db5779a5ac057c2 (diff)
downloadupstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.gz
upstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.bz2
upstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.zip
treewide: use wpad-basic-wolfssl as default
In order to support SAE/WPA3-Personal in default images. Replace almost all occurencies of wpad-basic and wpad-mini with wpad-basic-wolfssl for consistency. Keep out ar71xx from the list as it won't be in the next release and would only make backports harder. Build-tested (build-bot settings): ath79: generic, ramips: mt7620/mt76x8/rt305x, lantiq: xrx200/xway, sunxi: a53 Signed-off-by: Petr Štetiar <ynezz@true.cz> [rebase, extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/generic/target.mk2
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk2
-rw-r--r--target/linux/ath79/image/generic.mk4
-rw-r--r--target/linux/ath79/mikrotik/target.mk2
-rw-r--r--target/linux/ath79/nand/target.mk2
-rw-r--r--target/linux/ath79/tiny/target.mk2
6 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/ath79/generic/target.mk b/target/linux/ath79/generic/target.mk
index 88346efd2b..0624f79572 100644
--- a/target/linux/ath79/generic/target.mk
+++ b/target/linux/ath79/generic/target.mk
@@ -1,7 +1,7 @@
BOARDNAME:=Generic
FEATURES += squashfs
-DEFAULT_PACKAGES += wpad-basic
+DEFAULT_PACKAGES += wpad-basic-wolfssl
define Target/Description
Build firmware images for generic Atheros AR71xx/AR913x/AR934x based boards.
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 55d98ce508..b945183776 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -287,7 +287,7 @@ endef
TARGET_DEVICES += ubnt_rocket-m
define Device/ubnt_routerstation_common
- DEVICE_PACKAGES := -kmod-ath9k -wpad-mini -uboot-envtools kmod-usb-ohci \
+ DEVICE_PACKAGES := -kmod-ath9k -wpad-basic-wolfssl -uboot-envtools kmod-usb-ohci \
kmod-usb2 fconfig
DEVICE_VENDOR := Ubiquiti
SOC := ar7161
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index debb6722ca..4327512e17 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -938,7 +938,7 @@ define Device/iodata_etg3-r
DEVICE_VENDOR := I-O DATA
DEVICE_MODEL := ETG3-R
IMAGE_SIZE := 7680k
- DEVICE_PACKAGES := -iwinfo -kmod-ath9k -wpad-basic
+ DEVICE_PACKAGES := -iwinfo -kmod-ath9k -wpad-basic-wolfssl
endef
TARGET_DEVICES += iodata_etg3-r
@@ -998,7 +998,7 @@ define Device/jjplus_ja76pf2
SOC := ar7161
DEVICE_VENDOR := jjPlus
DEVICE_MODEL := JA76PF2
- DEVICE_PACKAGES += -kmod-ath9k -swconfig -wpad-mini -uboot-envtools fconfig
+ DEVICE_PACKAGES += -kmod-ath9k -swconfig -wpad-basic-wolfssl -uboot-envtools fconfig
IMAGES := kernel.bin rootfs.bin
IMAGE/kernel.bin := append-kernel
IMAGE/rootfs.bin := append-rootfs | pad-rootfs
diff --git a/target/linux/ath79/mikrotik/target.mk b/target/linux/ath79/mikrotik/target.mk
index face016a51..0394f4427d 100644
--- a/target/linux/ath79/mikrotik/target.mk
+++ b/target/linux/ath79/mikrotik/target.mk
@@ -1,7 +1,7 @@
BOARDNAME := MikroTik devices
FEATURES += minor nand squashfs
-DEFAULT_PACKAGES += wpad-basic
+DEFAULT_PACKAGES += wpad-basic-wolfssl
define Target/Description
Build firmware images for MikroTik devices based on Qualcomm Atheros
diff --git a/target/linux/ath79/nand/target.mk b/target/linux/ath79/nand/target.mk
index c565c9b2b8..a4069d7610 100644
--- a/target/linux/ath79/nand/target.mk
+++ b/target/linux/ath79/nand/target.mk
@@ -2,7 +2,7 @@ BOARDNAME := Generic devices with NAND flash
FEATURES += squashfs nand
-DEFAULT_PACKAGES += wpad-basic
+DEFAULT_PACKAGES += wpad-basic-wolfssl
define Target/Description
Firmware for boards using Qualcomm Atheros, MIPS-based SoCs
diff --git a/target/linux/ath79/tiny/target.mk b/target/linux/ath79/tiny/target.mk
index dba57e5965..2ee71ea921 100644
--- a/target/linux/ath79/tiny/target.mk
+++ b/target/linux/ath79/tiny/target.mk
@@ -1,7 +1,7 @@
BOARDNAME:=Devices with small flash
FEATURES += squashfs small_flash
-DEFAULT_PACKAGES += wpad-mini
+DEFAULT_PACKAGES += wpad-basic-wolfssl
define Target/Description
Build firmware images for Atheros AR71xx/AR913x/AR934x based boards with small flash