aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorMarcin Jurkowski <marcin1j@gmail.com>2018-12-11 16:14:21 +0100
committerChristian Lamparter <chunkeey@gmail.com>2018-12-15 21:35:45 +0100
commit3c3eaa57d9806dccae9f130cf608079f67097bed (patch)
treeeee97503d19b8c3cc08c08a48e8f84f37859a332 /target/linux/ath79
parent330965b342670def66d956d5a20009475ab30d0c (diff)
downloadupstream-3c3eaa57d9806dccae9f130cf608079f67097bed.tar.gz
upstream-3c3eaa57d9806dccae9f130cf608079f67097bed.tar.bz2
upstream-3c3eaa57d9806dccae9f130cf608079f67097bed.zip
ath79: add support for TP-Link TL-WR842N/ND v1 router
This ports support for TP-Link TL-WR842N/ND v1 from ar71xx. CPU: Atheros AR7241 400 MHz RAM: 32 MiB FLASH: 8 MiB PORTS: 4 Port 100/10 Switch, 1 Port 100/10 Wan WiFi: Atheros AR9287 LED: SYS, WiFi, LAN, WAN, 3G, QSS BTN: WiFi, Reset/WPS AR71xx target used "tl-mr3420" as board id so force flag is needed if upgrading from old target. Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [trivial cleanup]
Diffstat (limited to 'target/linux/ath79')
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom1
-rw-r--r--target/linux/ath79/dts/ar7241_tplink_tl-wr842n-v1.dts164
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk9
4 files changed, 175 insertions, 0 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index fa7a618909..43b537835c 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -172,6 +172,7 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth1" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
;;
+ tplink,tl-wr842n-v1|\
tplink,tl-wr842n-v2)
ucidef_set_interface_wan "eth0"
ucidef_add_switch "switch0" \
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
index e4d4a597a9..68943b4eb0 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
@@ -143,6 +143,7 @@ case "$FIRMWARE" in
tplink,tl-wr741-v1|\
tplink,tl-wr743nd-v1|\
tplink,tl-wr841-v7|\
+ tplink,tl-wr842n-v1|\
ubnt,airrouter|\
ubnt,bullet-m|\
ubnt,nano-m|\
diff --git a/target/linux/ath79/dts/ar7241_tplink_tl-wr842n-v1.dts b/target/linux/ath79/dts/ar7241_tplink_tl-wr842n-v1.dts
new file mode 100644
index 0000000000..282446b1e1
--- /dev/null
+++ b/target/linux/ath79/dts/ar7241_tplink_tl-wr842n-v1.dts
@@ -0,0 +1,164 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar7241.dtsi"
+
+/ {
+ compatible = "tplink,tl-wr842n-v1", "qca,ar7241";
+ model = "TP-Link TL-WR842N/ND v1";
+
+ aliases {
+ led-boot = &led_system;
+ led-failsafe = &led_system;
+ led-running = &led_system;
+ led-upgrade = &led_system;
+ };
+
+ keys {
+ compatible = "gpio-keys-polled";
+ poll-interval = <20>;
+
+ rfkill {
+ label = "rfkill";
+ linux,code = <KEY_RFKILL>;
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ led_system: system {
+ label = "tp-link:green:system";
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ };
+
+ qss {
+ label = "tp-link:green:qss";
+ gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+ };
+
+ led3g {
+ label = "tp-link:green:3g";
+ gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+ trigger-sources = <&hub_port>;
+ linux,default-trigger = "usbport";
+ };
+ };
+
+ ath9k-leds {
+ compatible = "gpio-leds";
+
+ wlan {
+ label = "tp-link:green:wlan";
+ gpios = <&ath9k 0 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+ };
+
+ gpio-export {
+ compatible = "gpio-export";
+
+ gpio_usb_power {
+ gpio-export,name = "tp-link:power:usb";
+ gpio-export,output = <1>;
+ gpios = <&gpio 6 GPIO_ACTIVE_HIGH>;
+ };
+ };
+};
+
+&usb {
+ #address-cells = <1>;
+ #size-cells = <0>;
+ status = "okay";
+
+ hub_port: port@1 {
+ reg = <1>;
+ #trigger-source-cells = <0>;
+ };
+};
+
+&usb_phy {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ reg = <0x0 0x20000>;
+ label = "u-boot";
+ read-only;
+ };
+
+ partition@20000 {
+ compatible = "tplink,firmware";
+ reg = <0x20000 0x7d0000>;
+ label = "firmware";
+ };
+
+ partition@7f0000 {
+ reg = <0x7f0000 0x10000>;
+ label = "art";
+ read-only;
+ };
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+
+ ath9k: wifi@0,0 {
+ compatible = "pci168c,002e";
+ reg = <0x0000 0 0 0 0>;
+ #gpio-cells = <2>;
+ gpio-controller;
+ qca,no-eeprom;
+ mtd-mac-address = <&uboot 0x1fc00>;
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ mtd-mac-address = <&uboot 0x1fc00>;
+ mtd-mac-address-increment = <(-1)>;
+};
+
+&eth1 {
+ status = "okay";
+
+ mtd-mac-address = <&uboot 0x1fc00>;
+ mtd-mac-address-increment = <1>;
+};
+
+&gpio {
+ status = "okay";
+};
+
+&uart {
+ status = "okay";
+};
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index b3f53e7469..3688c69fa4 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -99,6 +99,15 @@ define Device/tplink_tl-wr1043nd-v1
endef
TARGET_DEVICES += tplink_tl-wr1043nd-v1
+define Device/tplink_tl-wr842n-v1
+ $(Device/tplink-8m)
+ ATH_SOC := ar7241
+ DEVICE_TITLE := TP-LINK TL-WR842N/ND v1
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x8420001
+endef
+TARGET_DEVICES += tplink_tl-wr842n-v1
+
define Device/tplink_tl-wr842n-v2
$(Device/tplink-8mlzma)
ATH_SOC := ar9341