aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorKeith Maika <keithm@aoeex.com>2019-09-16 12:45:02 -0400
committerDavid Bauer <mail@david-bauer.net>2019-09-16 21:40:06 +0200
commit4cb5f296255889dd5e6bf0124badd414e85d27f5 (patch)
treec26e51af0053ce94faf8545beab6706f48c81812 /target/linux/ath79
parent38ccacf99b77bc3f10dd672e693ced598036ae7d (diff)
downloadupstream-4cb5f296255889dd5e6bf0124badd414e85d27f5.tar.gz
upstream-4cb5f296255889dd5e6bf0124badd414e85d27f5.tar.bz2
upstream-4cb5f296255889dd5e6bf0124badd414e85d27f5.zip
ath79: add support for TP-Link Archer C59v2
Add ath79 support for Archer C59v2, previously supported by ar71xx. TP-Link Archer C59v2 is a dual-band AC1350 router based on Qualcomm/Atheros QCA9561+QCA9886 chips. Specification: - 775/650/258 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - 3T3R 2.4 GHz - 2T2R 5 GHz - 5x 10/100 Mbps Ethernet - USB 2.0 port - UART header on PCB Flash instruction: - via web UI: 1. Download openwrt-ath79-generic-tplink_archer-c59-v2-squashfs-factory.bin 2. Login to router and open the Advanced tab 3. Navigate to System Tools -> Firmware Upgrade 4. Upload firmware using the Manual Upgrade form - via TFTP: 1. Set PC to fixed ip address 192.168.0.66 2. Download openwrt-ath79-generic-tplink_archer-c59-v2-squashfs-factory.bin and rename it to tp_recovery.bin 3. Start a tftp server with the file tp_recovery.bin in its root directory 4. Turn off the router 5. Press and hold Reset button 6. Turn on router with the reset button pressed and wait ~15 seconds 7. Release the reset button and after a short time the firmware should be transferred from the tftp server 8. Wait ~30 second to complete recovery. Signed-off-by: Keith Maika <keithm@aoeex.com>
Diffstat (limited to 'target/linux/ath79')
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds1
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata1
-rw-r--r--target/linux/ath79/dts/qca9561_tplink_archer-c59-v2.dts86
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk12
5 files changed, 102 insertions, 1 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index e317ce26e1..778316e450 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -157,6 +157,7 @@ tplink,tl-wr842n-v3)
;;
tplink,archer-c58-v1|\
tplink,archer-c59-v1|\
+tplink,archer-c59-v2|\
tplink,archer-c60-v1|\
tplink,archer-c60-v2)
ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x1E"
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index 7d5f288536..5b47af8ef7 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -59,7 +59,8 @@ ath79_setup_interfaces()
avm,fritz4020|\
pcs,cr3000|\
tplink,archer-c58-v1|\
- tplink,archer-c59-v1)
+ tplink,archer-c59-v1|\
+ tplink,archer-c59-v2)
ucidef_set_interface_wan "eth1"
ucidef_add_switch "switch0" \
"0@eth0" "1:lan:1" "2:lan:4" "3:lan:3" "4:lan:2"
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index ed3432273c..446b729a2b 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -214,6 +214,7 @@ case "$FIRMWARE" in
;;
tplink,archer-c58-v1|\
tplink,archer-c59-v1|\
+ tplink,archer-c59-v2|\
tplink,archer-c60-v1|\
tplink,archer-c60-v2|\
tplink,archer-c6-v2)
diff --git a/target/linux/ath79/dts/qca9561_tplink_archer-c59-v2.dts b/target/linux/ath79/dts/qca9561_tplink_archer-c59-v2.dts
new file mode 100644
index 0000000000..e70afbffd9
--- /dev/null
+++ b/target/linux/ath79/dts/qca9561_tplink_archer-c59-v2.dts
@@ -0,0 +1,86 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9561_tplink_archer-c5x.dtsi"
+
+/ {
+ compatible = "tplink,archer-c59-v2", "qca,qca9560";
+ model = "TP-Link Archer C59 v2";
+};
+
+&leds {
+ usb {
+ label = "tp-link:green:usb";
+ gpios = <&led_gpio 7 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "usbport";
+ trigger-sources = <&hub_port>;
+ };
+};
+
+&usb0 {
+ #address-cells = <1>;
+ #size-cells = <0>;
+ status = "okay";
+
+ hub_port: port@1 {
+ reg = <1>;
+ #trigger-source-cells = <0>;
+ };
+};
+
+&usb_phy0 {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "factory-boot";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "u-boot";
+ reg = <0x020000 0x010000>;
+ read-only;
+ };
+
+ mac: partition@30000 {
+ label = "mac";
+ reg = <0x030000 0x010000>;
+ read-only;
+ };
+
+ partition@40000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x040000 0xe10000>;
+ };
+
+ partition@e50000 {
+ label = "tplink";
+ reg = <0xe50000 0x1a0000>;
+ read-only;
+ };
+
+ art: partition@ff0000 {
+ label = "art";
+ reg = <0xff0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 1e63a6b2b4..5519e9c960 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -60,6 +60,18 @@ define Device/tplink_archer-c59-v1
endef
TARGET_DEVICES += tplink_archer-c59-v1
+define Device/tplink_archer-c59-v2
+ $(Device/tplink-safeloader-uimage)
+ ATH_SOC := qca9561
+ IMAGE_SIZE := 14400k
+ DEVICE_MODEL := Archer C59
+ DEVICE_VARIANT := v2
+ TPLINK_BOARD_ID := ARCHER-C59-V2
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca9888-ct
+ SUPPORTED_DEVICES += archer-c59-v2
+endef
+TARGET_DEVICES += tplink_archer-c59-v2
+
define Device/tplink_archer-c60-v1
$(Device/tplink-safeloader-uimage)
ATH_SOC := qca9561