aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-12-08 21:44:23 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-02-28 17:50:46 +0100
commit53ab9865c2b91bc6a239b2adee800dc52875b6bc (patch)
treefc5af7f6c75858c85e24e225d7df831f25deaada /target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch
parente1e6ff6648f5a0819a5b9429e787c1b6aacfec59 (diff)
downloadupstream-53ab9865c2b91bc6a239b2adee800dc52875b6bc.tar.gz
upstream-53ab9865c2b91bc6a239b2adee800dc52875b6bc.tar.bz2
upstream-53ab9865c2b91bc6a239b2adee800dc52875b6bc.zip
ath79: add support for kernel 5.4
Signed-off-by: David Bauer <mail@david-bauer.net> [refreshed] Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com> * Sync the patches with the changes done for kernel 4.19 * Use KERNEL_TESTING_PATCHVER * Refresh the configuration * Fix multiple compile bugs in the patches * Only add own ag71xx files for kernel 4.19 and use upstream version for 5.4. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch')
-rw-r--r--target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch b/target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch
new file mode 100644
index 0000000000..c26ef60725
--- /dev/null
+++ b/target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/parsers/Makefile
++++ b/drivers/mtd/parsers/Makefile
+@@ -1,3 +1,4 @@
++obj-$(CONFIG_MTD_PARSER_CYBERTAN) += parser_cybertan.o
+ # SPDX-License-Identifier: GPL-2.0-only
+ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
+--- a/drivers/mtd/parsers/Kconfig
++++ b/drivers/mtd/parsers/Kconfig
+@@ -94,6 +94,14 @@ config MTD_AFS_PARTS
+ for your particular device. It won't happen automatically. The
+ 'physmap' map driver (CONFIG_MTD_PHYSMAP) does this, for example.
+
++config MTD_PARSER_CYBERTAN
++ tristate "Parser for Cybertan format partitions"
++ depends on MTD && (ATH79 || COMPILE_TEST)
++ help
++ Cybertan has a proprietory header than encompasses a Broadcom trx
++ header. This driver will parse the header and take care of the
++ special offsets that result in the extra headers.
++
+ config MTD_PARSER_TRX
+ tristate "Parser for TRX format partitions"
+ depends on MTD && (BCM47XX || ARCH_BCM_5301X || COMPILE_TEST)