aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.15/910-unaligned_access_hacks.patch
diff options
context:
space:
mode:
authorJohn Audia <therealgraysky@proton.me>2023-08-03 13:53:47 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2023-08-10 21:06:55 +0200
commit795a5dd4529d7030fd141b9644a1752b863c2fd4 (patch)
tree4fc770389d8c44f9e653a06a30b3a0e936351c63 /target/linux/ath79/patches-5.15/910-unaligned_access_hacks.patch
parent11b0c43671af619f9acd129b44d52625ff5d1f42 (diff)
downloadupstream-795a5dd4529d7030fd141b9644a1752b863c2fd4.tar.gz
upstream-795a5dd4529d7030fd141b9644a1752b863c2fd4.tar.bz2
upstream-795a5dd4529d7030fd141b9644a1752b863c2fd4.zip
kernel: bump 5.15 to 5.15.124
Changelog: https://lore.kernel.org/stable/2023080341-curliness-salary-4158@gregkh/ 1. Needed to make a change to to package/kernel/linux/modules/netsupport.mk due to upstream moving vxlan to its own directory[1]. @john-tho suggested using the the 6.1 xvlan FILES to circumvent. 2. All patches automatically rebased. 1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.124&id=77396fa9096abdbfbb87d63e73ad44d5621cf103 Signed-off-by: John Audia <therealgraysky@proton.me> [Refreshed on top of OpenWrt 23.05] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit 81c1172c3626157ff9a146430cd14e32c9c80a5a)
Diffstat (limited to 'target/linux/ath79/patches-5.15/910-unaligned_access_hacks.patch')
-rw-r--r--target/linux/ath79/patches-5.15/910-unaligned_access_hacks.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ath79/patches-5.15/910-unaligned_access_hacks.patch b/target/linux/ath79/patches-5.15/910-unaligned_access_hacks.patch
index f542c32d45..1971b9cd01 100644
--- a/target/linux/ath79/patches-5.15/910-unaligned_access_hacks.patch
+++ b/target/linux/ath79/patches-5.15/910-unaligned_access_hacks.patch
@@ -654,7 +654,7 @@ SVN-Revision: 35130
return false;
return true;
-@@ -750,13 +754,13 @@ static inline void ipv6_addr_set_v4mappe
+@@ -746,13 +750,13 @@ static inline void ipv6_addr_set_v4mappe
*/
static inline int __ipv6_addr_diff32(const void *token1, const void *token2, int addrlen)
{
@@ -670,7 +670,7 @@ SVN-Revision: 35130
if (xb)
return i * 32 + 31 - __fls(ntohl(xb));
}
-@@ -950,17 +954,18 @@ static inline u32 ip6_multipath_hash_fie
+@@ -946,17 +950,18 @@ static inline u32 ip6_multipath_hash_fie
static inline void ip6_flow_hdr(struct ipv6hdr *hdr, unsigned int tclass,
__be32 flowlabel)
{