aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.10
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-09-30 11:26:47 +0200
committerFelix Fietkau <nbd@nbd.name>2022-09-30 11:28:51 +0200
commit4363faef8a8c975410f001858b010170942aacfc (patch)
tree6724d328151cc7066044fcb98330cfc40f1da54b /target/linux/ath79/patches-5.10
parenta0a4cfd83b9f09c4562c065d0017b389b2987263 (diff)
downloadupstream-4363faef8a8c975410f001858b010170942aacfc.tar.gz
upstream-4363faef8a8c975410f001858b010170942aacfc.tar.bz2
upstream-4363faef8a8c975410f001858b010170942aacfc.zip
kernel: move ubnt ledbar driver to a separate package
Simplifies the tree by removing a non-upstream kernel patch and related kconfig symbols Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ath79/patches-5.10')
-rw-r--r--target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch b/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
index 7505f682ab..4a721f2af2 100644
--- a/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
+++ b/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -941,6 +941,17 @@ config LEDS_UBNT_LEDBAR
- To compile this driver as a module, choose M here: the module
- will be called leds-ubnt-ledbar.
+@@ -931,6 +931,17 @@ config LEDS_ACER_A500
+
+ source "drivers/leds/blink/Kconfig"
+config LEDS_RESET
+ tristate "LED support for reset-controller API"
@@ -176,10 +176,10 @@ Signed-off-by: John Crispin <john@phrozen.org>
+MODULE_ALIAS("platform:leds-reset");
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -94,6 +94,7 @@ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds
+@@ -93,6 +93,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA) += leds
+ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
- obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
+obj-$(CONFIG_LEDS_RESET) += leds-reset.o
# LED SPI Drivers