aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2022-09-20 12:01:48 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-01 02:47:56 +0200
commitba6096d04b4f7a40aec339e7bf3f7b5842ae3cac (patch)
tree5542eb3332cf44995b052240ed32bcf7e9434beb /target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch
parentd5bf46bbe8f425182ea07787ae5d92145715da1b (diff)
downloadupstream-ba6096d04b4f7a40aec339e7bf3f7b5842ae3cac.tar.gz
upstream-ba6096d04b4f7a40aec339e7bf3f7b5842ae3cac.tar.bz2
upstream-ba6096d04b4f7a40aec339e7bf3f7b5842ae3cac.zip
ath79: Convert incorrect 5.10 and 5.15 patches
OpenWRT's developer guide prefers having actual patches so they an be sent upstream more easily. However, in this case, Adding proper fields also allows for `git am` to properly function. Some of these patches are quite old, and lack much traceable history. This commit tries to rectify that, by digging in the history to find where and how it was first added. It is by no means perfect and also shows some patches that should have been long gone. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch')
-rw-r--r--target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch b/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch
index 923589661e..cfc017871f 100644
--- a/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch
+++ b/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch
@@ -1,3 +1,21 @@
+From: Christian Lamparter <chunkeey@gmail.com>
+Subject: [PATCH] ath79: port cybertan_part from ar71xx
+
+This patch ports the cybertan_part code from ar71xx and converts the
+driver to a DT-supported mtd parser. As a result, it will no longer
+add the u-boot, nvram and art partitions, which were never part of
+the special Cybertan header.
+
+Instead these partitions have to be specified in the DT, which has the
+upside of making it possible to add properties (i.e.: read-only), labels
+and references to these important partitions.
+
+Submitted-by: Christian Lamparter <chunkeey@gmail.com>
+---
+ drivers/mtd/parsers/Makefile | 1 +
+ drivers/mtd/parsers/Kconfig | 8 ++++++++
+ 2 files changed, 9 insertions(+)
+
--- a/drivers/mtd/parsers/Makefile
+++ b/drivers/mtd/parsers/Makefile
@@ -8,6 +8,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o