aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.19/420-net-ar71xx_mac_driver.patch
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-12-13 15:14:10 +0800
committerPetr Štetiar <ynezz@true.cz>2019-03-24 01:44:25 +0100
commit3771176c9ef9b5d231e9019bc0c872dbe3617209 (patch)
tree361c1b460177d6e876d3402d3229d360a52bab71 /target/linux/ath79/patches-4.19/420-net-ar71xx_mac_driver.patch
parent4eaa3626a82149420d34b535dc673a2b6861da55 (diff)
downloadupstream-3771176c9ef9b5d231e9019bc0c872dbe3617209.tar.gz
upstream-3771176c9ef9b5d231e9019bc0c872dbe3617209.tar.bz2
upstream-3771176c9ef9b5d231e9019bc0c872dbe3617209.zip
ath79: add support for linux 4.19
The following patches are dropped because they are merged upstream: -0001-tty-serial-drop-QCA-pecific-SoC-symbols.patch -0006-usb-drop-deprecated-symbols.patch -0009-MIPS-ath79-add-lots-of-missing-registers.patch -0010-MIPS-ath79-add-support-for-QCA953x-QCA956x-TP9343.patch -0014-MIPS-ath79-finetune-cpu-overrides.patch -0015-MIPS-ath79-enable-uart-during-early_prink.patch -0016-MIPS-ath79-get-PCIe-controller-out-of-reset.patch This patch is dropped due to the introduction of spi-mem framework: -461-spi-ath79-add-fast-flash-read.patch Thank to Michael Marley @mamarley for his work on this patch: -910-unaligned_access_hacks.patch Signed-off-by: Chuanhong Guo <gch981213@gmail.com> [synchronized kernel config with make kernel_oldconfig] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ath79/patches-4.19/420-net-ar71xx_mac_driver.patch')
-rw-r--r--target/linux/ath79/patches-4.19/420-net-ar71xx_mac_driver.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-4.19/420-net-ar71xx_mac_driver.patch b/target/linux/ath79/patches-4.19/420-net-ar71xx_mac_driver.patch
new file mode 100644
index 0000000000..6377db0ac2
--- /dev/null
+++ b/target/linux/ath79/patches-4.19/420-net-ar71xx_mac_driver.patch
@@ -0,0 +1,28 @@
+--- a/drivers/net/ethernet/atheros/Kconfig
++++ b/drivers/net/ethernet/atheros/Kconfig
+@@ -5,7 +5,7 @@
+ config NET_VENDOR_ATHEROS
+ bool "Atheros devices"
+ default y
+- depends on PCI
++ depends on (PCI || ATH79)
+ ---help---
+ If you have a network (Ethernet) card belonging to this class, say Y.
+
+@@ -78,4 +78,6 @@ config ALX
+ To compile this driver as a module, choose M here. The module
+ will be called alx.
+
++source drivers/net/ethernet/atheros/ag71xx/Kconfig
++
+ endif # NET_VENDOR_ATHEROS
+--- a/drivers/net/ethernet/atheros/Makefile
++++ b/drivers/net/ethernet/atheros/Makefile
+@@ -3,6 +3,7 @@
+ # Makefile for the Atheros network device drivers.
+ #
+
++obj-$(CONFIG_AG71XX) += ag71xx/
+ obj-$(CONFIG_ATL1) += atlx/
+ obj-$(CONFIG_ATL2) += atlx/
+ obj-$(CONFIG_ATL1E) += atl1e/